Last Comment Bug 659832 - Make WebGL working on Maemo
: Make WebGL working on Maemo
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM MeeGo
: -- normal (vote)
: ---
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
: 580601 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-25 17:18 PDT by Oleg Romashin (:romaxa)
Modified: 2011-12-09 14:02 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WebGL initialization fix for Maemo (14.07 KB, patch)
2011-05-25 17:20 PDT, Oleg Romashin (:romaxa)
joe: review+
Details | Diff | Splinter Review
Fixed comments (14.50 KB, patch)
2011-06-09 11:44 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2011-05-25 17:18:30 PDT
I tried offscreenFBO on maemo6, latest SGX version and it does not render anything, last time we tried to found where is the problem and that was some drivers problem.

Here is the patch which is making EGL context init for content process working, also it switching maemo WebGL surface into to use GLContext bounded to XSurface, and related resizing changes.
Comment 1 Oleg Romashin (:romaxa) 2011-05-25 17:20:14 PDT
Created attachment 535240 [details] [diff] [review]
WebGL initialization fix for Maemo
Comment 2 Joe Drew (not getting mail) 2011-06-09 11:18:05 PDT
Comment on attachment 535240 [details] [diff] [review]
WebGL initialization fix for Maemo

Review of attachment 535240 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/GLContextProviderEGL.cpp
@@ +629,5 @@
> +                                             cxattribs);
> +        if (!context) {
> +            if (shareContext) {
> +                shareContext = nsnull;
> +                goto TRY_AGAIN_NO_SHARING;

I'd rather two separate calls to eglCreateContext than this goto. (I understand that you're just factoring out code, but we may as well make it prettier while we're at it! :) )

@@ +1806,2 @@
>  
> +    if (!glContext->Init()) {

This is already done in GLContextEGL, so I don't think it's necessary, right?

@@ +2087,5 @@
>      EGLSurface surface = 0;
>      EGLConfig config = 0;
>  
>  #ifdef MOZ_X11
> +    surface = CreateEGLSurfaceForXSurface(thebesSurface, &config, gUseBackingSurface ? 16 : 0);

Is there no way to get the bit-depth in a more portable way? EGL might not always be 16-bit only.
Comment 3 Oleg Romashin (:romaxa) 2011-06-09 11:44:34 PDT
Created attachment 538308 [details] [diff] [review]
Fixed comments
Comment 4 Oleg Romashin (:romaxa) 2011-06-10 07:36:02 PDT
http://hg.mozilla.org/mozilla-central/rev/1619d8fc6416
Comment 5 Ali Juma [:ajuma] 2011-12-09 14:02:15 PST
*** Bug 580601 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.