The default bug view has changed. See this FAQ.

GLXtest process should check for GLX >= 1.3 before calling glXCreatePixmap

RESOLVED FIXED in mozilla9

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
mozilla9
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Per http://support.mozilla.com/en-US/questions/820538

A user is getting this message:

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug! failed to create drawable
(Reporter)

Comment 1

6 years ago
Created attachment 535343 [details] [diff] [review]
check GLX version

David, can you please review this, as I remember that a while ago you had written code specifically to support older GLX. Does hardware acceleration on GLX <= 1.2 still matter? Currently GLXtest fails on it, so it's implicitly blacklisted. This patch just makes that clean and official. If we do want hw accel on GLX <= 1.2 then GLXtest needs to be modified to no longer use glXCreatePixmap.
Attachment #535343 - Flags: review?(dbaron)
Comment on attachment 535343 [details] [diff] [review]
check GLX version

Looks fine to me; the case where I had GLX 1.2 was Intel video on Ubuntu 10.04, which no longer works due to the X error handling stuff.  (Intel on Ubuntu 11.04 is fine; it has GLX 1.4.)

r=dbaron
Attachment #535343 - Flags: review?(dbaron) → review+

Comment 3

6 years ago
This is also a problem with at least the latest release of Debian (squeeze).  It is also still running OpenGL 1.2 with the Intel drivers.  If Firefox is only supporting a minimum version of OpenGL, it should at least tell you that's the reason that it's kacking.

Fwiw, it's not just glXCreatePixmap.  It's also glXDestroyPixmap.

Btw...do I understand the last comment from David Baron correctly?  Even if I install the latest Intel drivers on Ubuntu 10.04, it still won't work?  If that's true, the take up on this feature might be diminished on Linux, due to the large percentage of desktop users on Ubuntu.  I'm sure most of them are probably corporate, too, which aren't going to want to move off of an LTS release.
(Reporter)

Comment 4

6 years ago
We were talking about the GLX version here, not the OpenGL version. A system implementing only OpenGL 1.2 would be a system from the 1990s and it wouldn't be able to run WebGL anyways (OpenGL 2.1 is required).

You just can't install the latest intel drivers on an older Ubuntu release like 10.04, because on X11 the drivers are too intermingled with other layers such as Mesa, the X server, libdri, etc.

I agree it's important to generate precise and useful error messages, but in the case of a Ubuntu 10.04 user, he'd be using Mesa 7.7 while we require Mesa 7.10 so he'd get the message saying that this driver version is too old, suggesting to try "Mesa 7.10". Hopefully he'd realize that means upgrade Ubuntu versions, because of the way that linux distros work.

Comment 5

6 years ago
I am getting this error since upgrading to Firefox 6.0

The full text is:
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported!  This is an application bug!
Blocks: 594876
(Reporter)

Comment 6

6 years ago
Oops, somehow this never landed. Doing it ASAP.
(Reporter)

Comment 7

6 years ago
http://hg.mozilla.org/mozilla-central/rev/39fd1683ee6f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
I am getting the same error for all Versions of Firefox I am trying to use on Linux x86 32bit.

5.0.1
6.0.0
6.0.1
6.0.2
7.0b6

The error is:

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
failed to create drawable

I am on Gentoo but I installed directly from Firefox.com

I was able to restart with "firefox -safe-mode" but that also no longer works ;(

Best
Zeno

Comment 9

6 years ago
Ok, solved. Somehow FF was still running in the background without telling me. Killing FF with "killall -KILL firefox-bin" helped.

I also upgraded my NVIDIA drivers.

Best
Zeno

Updated

6 years ago
Hardware: x86_64 → All
Target Milestone: --- → mozilla9

Updated

5 years ago
Duplicate of this bug: 709034
(Reporter)

Updated

5 years ago
Duplicate of this bug: 709033
You need to log in before you can comment on or make changes to this bug.