Closed Bug 709034 Opened 11 years ago Closed 11 years ago

GLX related error message appears when started from a cmdline

Categories

(Thunderbird :: General, defect)

8 Branch
x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 659932

People

(Reporter: hawran.diskuse, Unassigned)

Details

User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111115192257

Steps to reproduce:

I started Thunderbird from a command line.


Actual results:

The error messages appeared as follows:

WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported!  This is an application bug!


Expected results:

No error message at all.

PS Ubuntu 10.04, thunderbird 8.0+build1-0ubuntu0.10.04.1~mts2
(In reply to hawran from comment #0)
So this is just a warning but Thunderbird still starts? 

Also, the Thunderbird build is from the Ubuntu packages so therefore they're responsible for the build. In my opinion, you should report this error to them.
That error message indicates that your Ubuntu version is shipping with GLX 1.2 or earlier, whereas current Mozilla applications are apparently linked against 1.4 (see http://forums.mozillazine.org/viewtopic.php?f=40&t=2380547 for a similar case with a corresponding SeaMonkey 2.5 installation on Linux Mint 9). Thus, updating whatever provides that on Ubuntu should make the warning disappear.
Also see Core bug 659932 for reference and related discussions.
Per discussion in the forum thread, glXCreatePixmap and glXDestroyPixmap are no longer invoked if an insufficient GLX version is detected in current betas. Instead, a respective message is logged in the Error Console of the application.

(In reply to Hashem Masoud from comment #1)
> Also, the Thunderbird build is from the Ubuntu packages so therefore they're
> responsible for the build. In my opinion, you should report this error to them.

The solution is to update the Ubuntu installation to 11.04 or later, which should provide the needed GLX version.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659932
I am NOT upgrading from my Ubuntu 10.04 version as long as this is the latest LTS version.
However, point taken and I'll report it to Ubuntu support.
Yes, that's the trade-off with these LTS releases. You can stay on the branches you're used to for much longer and still get security updates, but when an application needs a newer version of a specific library it may not find it.

As it appears, this seems to be a performance issue only (though I don't know the exact implications of the GLX fallback) with hardware acceleration not used in this case.
You need to log in before you can comment on or make changes to this bug.