First startup after automatic installation gets APP_STARTUP instead of ADDON_INSTALL

RESOLVED DUPLICATE of bug 854937

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 854937
7 years ago
5 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
For a boostrapped add-on that gets automatically installed (perhaps by distribution or upgrade(?)), its startup gets called with APP_STARTUP.

That's arguably correct, except now bootstrapped add-ons can't rely on ADDON_INSTALL for startup reason, which is what they normally get if the user manually installs the add-on.

Workaround: Track ADDON_INSTALL from install() and check it from startup().
Blocks: 852623
Is this something that can be fixed Dave?
Flags: needinfo?(dtownsend+bugmail)
Not only can we fix it, but we already have
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dtownsend+bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 854937
You need to log in before you can comment on or make changes to this bug.