The default bug view has changed. See this FAQ.

text-shadow drawn on top of text-decoration (underline) in standards mode

RESOLVED FIXED in mozilla8

Status

()

Core
Layout: Text
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: alex, Unassigned)

Tracking

Trunk
mozilla8
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-2011-05-27])

Attachments

(1 attachment)

506 bytes, text/html
Details
(Reporter)

Description

6 years ago
User-Agent:       Opera/9.80 (Windows NT 6.1; U; en) Presto/2.8.131 Version/11.11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When using text-shadow on an "a" element with :hover {underline} the shadow for the text appears over the underline.

Reproducible: Always

Steps to Reproduce:
1. Create an "a" element and apply the "text-shadow" style to it.
2. Create a :hover style that displays the underline for the "a" element.
3. Notice overlap of shadow.


Expected Results:  
Shadow to appear below underline
Care to attach a reduced Testcase showing the Issue?
Version: unspecified → 4.0 Branch
(Reporter)

Comment 2

6 years ago
Created attachment 535666 [details]
Test
Attachment #535666 - Attachment mime type: text/plain → text/html
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110527 Firefox/7.0a1 ID:20110527030642

Opera 11.50 and Google Chrom 13 dev get it right.
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 4.0 Branch → Trunk

Comment 4

6 years ago
Can confirm on Linux, Firefox 5 beta.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Whiteboard: [bugday-2011-05-27]
Bug 403524 will fix this.
Depends on: 403524
Summary: text-shadow overlaps :hover underline → text-shadow drawn on top of text-decoration (underline) in standards mode

Updated

6 years ago
Duplicate of this bug: 672161

Comment 7

6 years ago
The patch for bug 403524 merges our text-decoration codepaths for both quirks- and standards-mode, drawing shadows behind both the text and its decorations in all modes.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.