Fix Threadpane context menu after nsContextMenu clean up

RESOLVED FIXED in seamonkey2.4

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Tracking

({regression})

Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.2 fixed, seamonkey2.3 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

8 years ago
At the moment the thread pane context menu is not working as it should following the nsContextMenu clean up (Bug 655863).
This patch:
* Moves return from setTarget so variables are initialised.
* Calls initItems to hide unneeded menuitems/separators.
Attachment #535892 - Flags: review?(neil)
Comment on attachment 535892 [details] [diff] [review]
Fix to thread pane context patch

>+    if (aNode.namespaceURI == xulNS || this.isTargetAFormControl(aNode)) {
>+      this.shouldDisplay = false;
>+      return;
>+    }
>+
>     this.autoDownload = Components.classes["@mozilla.org/preferences-service;1"]
>                                   .getService(Components.interfaces.nsIPrefBranch)
>                                   .getBoolPref("browser.download.useDownloadDir");
> 
>     // Clear any old spellchecking items from the menu, this used to
>     // be in the menu hiding code but wasn't getting called in all
>     // situations. Here, we can ensure it gets cleaned up any time the
>     // menu is shown.
Except that's not true if we return first! Some of the items expect this.autoDownload to be defined, and you also need to clear isTextSelected, isContentSelected and popupURL. (In the latter case you can move the line from initPopupURL into setTarget.)
Attachment #535892 - Flags: review?(neil) → review-
Assignee

Comment 2

8 years ago
Changes since last version:
* Added suggested variables to initialisation list.
* Moved return to after spellcheck cleardown.
Attachment #535892 - Attachment is obsolete: true
Attachment #535959 - Flags: review?(neil)
Attachment #535959 - Flags: review?(neil) → review+
Assignee

Comment 3

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

http://hg.mozilla.org/comm-central/rev/0a9a8f6999ab
Attachment #535959 - Attachment description: Revised fix for thread pane context → Revised fix for thread pane context [Checked in: Comment 3]
Assignee

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.2
Assignee

Updated

8 years ago
Whiteboard: [SM24]
Target Milestone: seamonkey2.2 → Future
Assignee

Comment 4

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

Also need this for comm-beta
Attachment #535959 - Flags: approval-comm-aurora?

Comment 5

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

a=me regression fix.
Attachment #535959 - Flags: approval-comm-aurora? → approval-comm-aurora+
Assignee

Comment 6

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

http://hg.mozilla.org/releases/comm-aurora/rev/d1604275086f
Attachment #535959 - Attachment description: Revised fix for thread pane context [Checked in: Comment 3] → Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6]
Assignee

Updated

8 years ago
Whiteboard: [SM24]
Target Milestone: Future → seamonkey2.4
Assignee

Updated

8 years ago
Attachment #535959 - Flags: approval-comm-beta?

Comment 7

8 years ago
If it's landed in comm-aurora won't it get into comm-beta automatically after the next merge? I'm entirely unclear about the mechanics of the new rapid release process ;-(

Comment 8

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

Ratty, you're right that beta will get it with the next uplift from aurora, but SeaMonkey is targeting to ship 2.2 from what's currently in beta - what's currently aurora will become 2.3, then.
Attachment #535959 - Flags: approval-comm-beta? → approval-comm-beta+
Assignee

Comment 9

8 years ago
Comment on attachment 535959 [details] [diff] [review]
Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]

http://hg.mozilla.org/releases/comm-beta/rev/f3cc36e1725e
Attachment #535959 - Attachment description: Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6] → Revised fix for thread pane context [Checked in: trunk Comment 3, aurora Comment 6, beta Comment 9]
Assignee

Updated

8 years ago
Target Milestone: seamonkey2.4 → seamonkey2.2
Target Milestone: seamonkey2.2 → seamonkey2.4
You need to log in before you can comment on or make changes to this bug.