If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

deleting private data takes ages (manually or at closing time)

RESOLVED DUPLICATE of bug 645471

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 645471
6 years ago
5 years ago

People

(Reporter: logos, Unassigned)

Tracking

5 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

hi,

this has happened before (in Minefield versions of FF4), that was solved, and this has been happening again for a couple of weeks now in FF5 (Aurora builds) and now of course in FF5beta. Clearing "all" private data takes between 15 and 30 seconds, even after just a few minutes in a new session (knowing that all history was already cleared in the last session).
 You get the cleaning dialog showing a "not responding" message, ie it can't be moved, the UI is frozen, also duplicating itself (2 superposed dialog boxes) but the process of cleaning is actually going on and the dialog closes when it's finally finish.
 
 Same goes of course when closing the browser and it's set to clear private data at closing time: it takes ages and ages: hard disk activity, no way to restart Firefox until the process of clear has completed, well you got the idea.

 Thanks for looking into that.

Reproducible: Always
(Reporter)

Updated

6 years ago
Version: unspecified → 5 Branch
Is this happening too if you unset to delete "Cookies"?
(Reporter)

Comment 2

6 years ago
indeed it doesn't seem to be as bad when I deselect cookies. Still too long with the "not responding" message appearing but actually much shorter than if cookies were included in the deletion process. That's weird as cookies should actually be the fastest stuff to delete.
The Cookie Part alone would be Bug 645471.
So the Rest is bound to Cache Usage?
In "about:cache" ("Disk cache device"), what are the Values for "Number of entries", "Maximum storage size" & "Storage in use"?

Else can you pinpoint this to a certain Area what gets deleted in the Dialog?
(Reporter)

Comment 4

6 years ago
yes the rest is cache usage...


Number of entries: 	519
Maximum storage size: 	640000 KiB
Storage in use: 	4152 KiB

...the cache folder (FF profile) is currently 2.19MB big while as mentioned "storage in use" is about 4MB... don't know if the two numbers must be relevant...
Component: Bookmarks & History → Networking: Cache
Product: Firefox → Core
QA Contact: bookmarks → networking.cache

Comment 5

6 years ago
This is a dupe of bug 645471 and bug 660195. I'm going to dupe this against the plugin loading since if that is a factor it is probably worse than the other factors.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645471
You need to log in before you can comment on or make changes to this bug.