Closed Bug 645471 Opened 13 years ago Closed 3 years ago

Clearing cookies hangs browser due to plug-ins cookies deletion

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hagargi, Unassigned)

References

Details

(Keywords: hang)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

On usage of "Clear History", with all options selected, The browser hangs for few minutes and gives below alert message.

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/sanitize.js:136

Reproducible: Always

Actual Results:  
A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/sanitize.js:136

Expected Results:  
Timely completion of task
Do you get any relevant Errors in the Error Console?
Component: General → Private Browsing
QA Contact: general → private.browsing
Version: unspecified → 4.0 Branch
ERROR CONSOLE:
Could not read chrome manifest file 'D:\Program Files\Mozilla Firefox\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest'.
I think the error is happening somewhere around here: <http://mxr.mozilla.org/mozilla-central/source/browser/base/content/sanitize.js#174>, which makes me think that this might be related to clearing plugin data.

sanjay, can you please post the contents of the about:support page here?  Thanks!
I've see reports of this happening exactly with plug-ins clear, you could try to uncheck the clear cookies field and see if it still hangs, if it won't hang it's most likely that problem.
Marco Bonardo is right. When i unchecked cookies, it did not hang.
Component: Private Browsing → Plug-ins
Product: Firefox → Core
QA Contact: private.browsing → plugins
Summary: Clear Recent History - Hangs: Detailed error alert message → Claring cookies hangs browser due to plug-ins cookies deletion
Version: 4.0 Branch → Trunk
Confirming because I've seen other reports around forums. Could be related to bug 633427 but this is a hang.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
Summary: Claring cookies hangs browser due to plug-ins cookies deletion → Clearing cookies hangs browser due to plug-ins cookies deletion
The "clear now" feature hangs a while when all options are selected in "clear all history". After a while i get warning on non responsive script.
I have two machines with Firefox 4--one installation has this bug and the other doesn't. I compared the chrome.manifest and binary.manifest files of both installations. The manifest files on the installation that hangs had the following entries:

chrome.manifest: manifest components/binary.manifest□
binary.manifest: binary-component xpcomsample.dll□binary-component browsercomps.dll□

The manifest files on the installation that doesn't hang have the following entries:

chrome.manifest: manifest components/binary.manifest
binary.manifest: binary-component xpcomsample.dllbinary-component browsercomps.dll

I closed Firefox and deleted those squares from the manifest files. This seems to have fixed the problem as I can now clear recent history with cookies checked. Can anyone confirm?
I just received the error message again, even though my fix above seemed to work for a few days.
I got this message when I clicked on Clear History:

" A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/sanitize.js:136 "
Has (in the location bar without the quotes "chrome://browser/content/sanitize.js" ) been changed in Firefox 4.0?
Ok, I *think* the issue is now resolved.  It was either the outdated Java plugin or a Citrix plugin.  I updated my Java plugin, and deleted the Citrix plugin.  All is well now.

Solution to resolve my issue:
Went here:  http://www.mozilla.com/en-US/plugincheck/  clicked on the ones I needed to be updated.  For the Citrix ICA plugin, it said "research".  A lot of people use Citrix, so hopefully it will be a plugin supported by Firefox, but I don't need it, and hence, I removed it.  After updating the Java plugin, I cleared history, and all is well.  So, it was either the Java plugin or the Citrix plugin.  Hope this helps!  More info of similar solution here:  http://support.mozilla.com/en-US/questions/792258#answer-160636

Recommendations for Firefox bug slayers:  I recommend to have the Plugin Check webpage actually part of Firefox (either automatically when users update Firefox, and/or as part of the help menu.)  I did not realize there was a plugin check webpage officially supported by Firefox and from my research, it seems that a lot of other users are having the same issue.  It's funny how Clear Private Data is linked to plugins, even when these plugins are not activated.  PLEASE PLEASE PLEASE have the Plugin Check webpage as part of your Help Menu.  It will save you guys a lot of time, effort, and headaches for the Bugzilla team.  Thank-you Marco Bonardo.  Kudos.
Unfortunately, I don't have a Citrix or Java plugin installed, and all of my plugins are up to date, so that fix is probably not the answer.
Although this is a separate issue (because it's an Adobe Acrobat plugin bug I'm having and not a Firefox bug), if you have Adobe Acrobat plugin (or even the Adobe Flash plugin), temporarily disable it and see if the issue is the same.  I am having major problems with the Acrobat plugin, and I'm hearing from the interwebs of freezing/slowdowns of the Adobe Flash plugin (in combination with other plugins) from some people with Firefox 4.
I recently updated to Firefox 5 Beta 2.0 and am still receiving this error message, albeit less often than before.
Can anyone with this problem confirm that they also have the Quicktime plugin installed? I removed mine and it seems to have taken care of this issue for now.
The problem still persist after I disable the Quicktime plugin. With this message:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/sanitize.js:136"
I'd never had this problem before. I updated to Firefox 6 and now it hangs when I try to clear the cookies, as described here. I don't have Quicktime plugin installed.
I've gotten this problem and the unresponsive script comes up as "chrome://browser/content/sanitize.js:33"

I opened process explorer and watched as Firefox opened several plugin-containers as it was clearing my history.

version: Firefox 6
The browser hangs also when clearing only Cache , not just Cookies. The hangs problem is related to Cache too, not just cookies.

I selected only Cache in the Clear History dialog, and it hangs for over a minute.
The time range was set as "Everything"
This is unacceptable.
I forgot to mention - the last comment (comment 26) was with Nightly 16.0a1 (2012-06-10)

Sorry for the bug spam.
I have the same problem in Ubuntu x64 with Firefox 17.0.1. I have multiple profiles for various purposes, and the plugins are shared between all profiles in shared "plugins" dir (so, everywhere the same). I don't have the QuickTime plugin at all. 

I have this problem in some profiles, and in some others - not. I suspected that one of the addons causes this, but I installed the same addons to the profile where this problem is not present and it's still doesn't occur there.

So in my opinion neither plugins nor addons cause this. I'd recommend to check whether this might be present only in profiles which has been migrated from previous firefox installation (my current suspicion).
Unfortunately not on migrated profiles. I'm today on a fresh profile and have this problem too.
Resolving as wont fix, plugin support deprecated in Firefox 85.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.