Closed Bug 660809 Opened 8 years ago Closed 8 years ago

about:license on Thunderbird

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(blocking-thunderbird5.0 beta2+, thunderbird5.0 beta2-fixed, thunderbird6 fixed)

VERIFIED FIXED
Thunderbird 7.0
Tracking Status
blocking-thunderbird5.0 --- beta2+
thunderbird5.0 --- beta2-fixed
thunderbird6 --- fixed

People

(Reporter: baffclan, Assigned: standard8)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to Reproduce:
1. Start Thunderbird
2. Help -> About Shredder
3. apear about dialog
4. click "Licensing Information"
5. Opan about:license on new tab
6. Click "Mozilla Public License" link on about:license

Actual Results:
Apear "Lanch Application"

Expected Results:
Jamp to Mozilla Public License(#mpl)
OS: Windows XP → All
Hardware: x86 → All
blocking-thunderbird5.0: --- → needed
blocking-thunderbird5.0: needed → beta2+
Blocks: 659527
This fixes both this and bug 659527.

I did a cut-down function so that we could use the specialTabs.aboutClickHandler, and made sure we'd covered all the links.

I tested the manual download link changes by replacing "noUpdatesFound" in onCheckComplete with "manualUpdate" and "downloadFailed".
Assignee: nobody → mbanner
Status: NEW → ASSIGNED
Attachment #537792 - Flags: review?(jonathan.protzenko)
Comment on attachment 537792 [details] [diff] [review]
The fix (for Miramar/Aurora)

Review of attachment 537792 [details] [diff] [review]:
-----------------------------------------------------------------

So I'm giving r- because I don't think it's such a good idea to go duplicating similar functions all over the place, but I'm willing to discuss this over IRC :-).

::: mail/base/content/aboutDialog.js
@@ +88,3 @@
>  #endif
>  }
>  

The function below basically copies everything from openContentTab: http://mxr.mozilla.org/comm-central/source/mail/base/content/utilityOverlay.js#231

Couldn't we just factor out the two into some common function that takes an third parameter that could be either { type: "about" } or { type: "content", regexp: theRegExp }...? I'm not that enthusiastic about happily duplicating code.

We could redirect both openAboutTab and openContentTab to be calls to third function with the right parameters.

::: mail/base/content/aboutDialog.xul
@@ +67,4 @@
>          >
>  
>    <script type="application/javascript" src="chrome://messenger/content/aboutDialog.js"/>
> + <script type="application/javascript" src="chrome://messenger/content/specialTabs.js"/>

Nit: this does not seem to be aligned.
Attachment #537792 - Flags: review?(jonathan.protzenko) → review-
Oh and I tested this of course and this fixes both this bug and bug 659527
Comment on attachment 537792 [details] [diff] [review]
The fix (for Miramar/Aurora)

I'm appealing ;-) I agree with re-using the function, but I think for Miramar, and possibly Aurora, I don't want to change that function definition in utilityOverlay. Whilst I suspect no add-ons are using it yet, I'd just prefer not to just in case.
Attachment #537792 - Attachment description: The fix → The fix (for Miramar/Aurora)
Attachment #537792 - Flags: review- → review?(jonathan.protzenko)
Comment on attachment 537792 [details] [diff] [review]
The fix (for Miramar/Aurora)

Alright :-). Can you create a followup bug for factoring the two functions? You can assign to me if you wish.
Attachment #537792 - Flags: review?(jonathan.protzenko) → review+
Blocks: 663112
Filed bug 663112 on the follow-up.

Checked in: http://hg.mozilla.org/comm-central/rev/08be6ad1285b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0
Attachment #537792 - Flags: approval-thunderbird5.0+
Attachment #537792 - Flags: approval-comm-aurora?
Thanks for fixing this.

cannot reproduce with :
Shredder-20110611/WinVista, WinXP
Miramar-20110612/WinVista
Status: RESOLVED → VERIFIED
Attachment #537792 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.