Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 661518 - about:home page is not repainted correctly when it comes back in focus
: about:home page is not repainted correctly when it comes back in focus
: regression, verified-aurora, verified-beta
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 7 Branch
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Jeff Muizelaar [:jrmuizel]
: Milan Sreckovic [:milan] (PTO through Oct 23)
: 661709 662711 (view as bug list)
Depends on: 678505
  Show dependency treegraph
Reported: 2011-06-02 06:33 PDT by Cristian Nicolae (:xti)
Modified: 2011-08-30 10:41 PDT (History)
17 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

screenshot (45.79 KB, image/png)
2011-06-02 06:33 PDT, Cristian Nicolae (:xti)
no flags Details
Screenshot 2 (43.45 KB, image/png)
2011-06-03 01:28 PDT, Cristian Nicolae (:xti)
no flags Details
AMO screenshot (60.52 KB, image/png)
2011-08-16 04:16 PDT, Cristian Nicolae (:xti)
no flags Details

Description Cristian Nicolae (:xti) 2011-06-02 06:33:23 PDT
Created attachment 536871 [details]

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/201100601
Firefox/7.0a1 Fennec/7.0a1
Device: LG Optimus 2x
OS: Android 2.2

Steps to reproduce:
1. Open Fennec App
2. Go to about:home
3. Open any webpage in a new tab
4. Pan right for tabs panel
5. Tap on about:home tab
6. Pan left to hide tabs panel

Expected result:
about:home page is repainted correctly .

Actual result:
After step 6, for several seconds some areas of about:home page are semi transparent. Please see the attached screenshot.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-02 17:43:05 PDT
*** Bug 661709 has been marked as a duplicate of this bug. ***
Comment 2 Cristian Nicolae (:xti) 2011-06-03 01:26:19 PDT
I've noticed the same result if at step 2, you go to about:testharness
Comment 3 Cristian Nicolae (:xti) 2011-06-03 01:28:47 PDT
Created attachment 537106 [details]
Screenshot 2
Comment 4 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-06-13 09:20:26 PDT
*** Bug 662711 has been marked as a duplicate of this bug. ***
Comment 5 Cristian Nicolae (:xti) 2011-07-15 05:43:45 PDT
This issue doesn't occur on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110527
Firefox/7.0a1 Fennec/7.0a1

but it occurs on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110528
Firefox/7.0a1 Fennec/7.0a1

Possible range:
Comment 6 Kevin Brosnan [:kbrosnan] 2011-07-15 14:06:15 PDT
Regression from the Cairo update?
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-15 14:49:15 PDT
(In reply to comment #6)
> Regression from the Cairo update?

That was my guess too
Comment 8 Kevin Brosnan [:kbrosnan] 2011-07-20 22:14:04 PDT
The following change set is good

The following change set is bad

So the Cairo update is the problem.
Comment 9 Doug Turner (:dougt) 2011-07-21 10:01:53 PDT
jmuizelaar, do you know about this?
Comment 10 Aaron Train [:aaronmt] 2011-07-29 07:18:12 PDT
Reproducable by simply panning around about:home
Comment 11 Aaron Train [:aaronmt] 2011-08-11 08:22:00 PDT
I feel like bug 665510 is related or exactly the same issue here
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2011-08-11 11:44:39 PDT
not tracking for 7 at this point, depending on the fix we may uplift
Comment 13 Jeff Muizelaar [:jrmuizel] 2011-08-12 12:30:48 PDT
Can folks reproduce this reliably? I've seen it a bit, but nothing reliable.
Comment 14 Aaron Train [:aaronmt] 2011-08-12 12:34:09 PDT
(In reply to Jeff Muizelaar [:jrmuizel] from comment #13)
> Can folks reproduce this reliably? I've seen it a bit, but nothing reliable.

Really all you need to do is pan around, (reproducible in Nightly 08/12)
Comment 15 Ali Juma [:ajuma] 2011-08-12 12:35:59 PDT
I can also reproduce this by panning around about:home.
Comment 16 Cristian Nicolae (:xti) 2011-08-16 04:16:35 PDT
Created attachment 553435 [details]
AMO screenshot

When I type something in the AMO search field, a black dash is displayed on the bottom of the input field . I'm able to reproduce it on the latest Nightly build. Is it related to this bug?

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110815
Firefox/8.0a1 Fennec/8.0a1
Device: HTC Desire Z
OS: Android 2.3.3
Comment 17 Jeff Muizelaar [:jrmuizel] 2011-08-17 11:20:18 PDT
It looks like the patch on bug 668921 might fix this.
Comment 18 Jeff Muizelaar [:jrmuizel] 2011-08-22 12:38:30 PDT
Can anyone still reproduce this since bug 668921 landed?
Comment 19 Kevin Brosnan [:kbrosnan] 2011-08-22 21:35:50 PDT
Appears that the patch for bug 668921 fixed this. Panned around about:home for a few minutes without seeing any painting issue. Tested Aurora and the issue appeared after a short amount of panning.
Comment 20 Andreea Pod 2011-08-26 00:50:11 PDT
Verified fixed on: Mozilla /5.0 (Android;Linux armv7l;rv:7.0) Gecko/20110824 Firefox/9.0a1 Fennec/7.0
Device: LG Optimus 2X

Note You need to log in before you can comment on or make changes to this bug.