The default bug view has changed. See this FAQ.

about:home page is not repainted correctly when it comes back in focus

VERIFIED FIXED

Status

()

Core
Graphics
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: xti, Assigned: jrmuizel)

Tracking

({regression, verified-aurora, verified-beta})

7 Branch
ARM
Android
regression, verified-aurora, verified-beta
Points:
---

Firefox Tracking Flags

(firefox7 fixed, firefox8 fixed, fennec7+)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 536871 [details]
screenshot

Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/201100601
Firefox/7.0a1 Fennec/7.0a1
Device: LG Optimus 2x
OS: Android 2.2

Steps to reproduce:
1. Open Fennec App
2. Go to about:home
3. Open any webpage in a new tab
4. Pan right for tabs panel
5. Tap on about:home tab
6. Pan left to hide tabs panel

Expected result:
about:home page is repainted correctly .

Actual result:
After step 6, for several seconds some areas of about:home page are semi transparent. Please see the attached screenshot.
Duplicate of this bug: 661709
(Reporter)

Comment 2

6 years ago
I've noticed the same result if at step 2, you go to about:testharness
(Reporter)

Comment 3

6 years ago
Created attachment 537106 [details]
Screenshot 2
Keywords: regressionwindow-wanted

Updated

6 years ago
Priority: -- → P2
Duplicate of this bug: 662711
(Reporter)

Comment 5

6 years ago
This issue doesn't occur on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110527
Firefox/7.0a1 Fennec/7.0a1
http://hg.mozilla.org/mozilla-central/rev/503990b2c5c6

but it occurs on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110528
Firefox/7.0a1 Fennec/7.0a1
http://hg.mozilla.org/mozilla-central/rev/9260bd59d5ce

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=503990b2c5c6&tochange=9260bd59d5ce
Regression from the Cairo update?
(In reply to comment #6)
> Regression from the Cairo update?

That was my guess too
The following change set is good
20110720181347
https://hg.mozilla.org/mozilla-central/rev/503990b2c5c6

The following change set is bad
20110715150747
https://hg.mozilla.org/mozilla-central/rev/04e8d0b481bc

So the Cairo update is the problem.
Component: General → Graphics
Product: Fennec → Core
QA Contact: general → thebes
Version: Trunk → 7 Branch
tracking-fennec: --- → ?
status-firefox7: --- → affected
status-firefox8: --- → affected

Comment 9

6 years ago
jmuizelaar, do you know about this?
tracking-fennec: ? → 7+
Reproducable by simply panning around about:home
(Assignee)

Updated

6 years ago
Assignee: nobody → jmuizelaar
Keywords: regressionwindow-wanted
Keywords: regression
I feel like bug 665510 is related or exactly the same issue here

Updated

6 years ago
Status: NEW → ASSIGNED
not tracking for 7 at this point, depending on the fix we may uplift
tracking-fennec: 7+ → 8+
(Assignee)

Updated

6 years ago
Depends on: 678505
(Assignee)

Comment 13

6 years ago
Can folks reproduce this reliably? I've seen it a bit, but nothing reliable.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #13)
> Can folks reproduce this reliably? I've seen it a bit, but nothing reliable.

Really all you need to do is pan around, (reproducible in Nightly 08/12)

Comment 15

6 years ago
I can also reproduce this by panning around about:home.
(Reporter)

Comment 16

6 years ago
Created attachment 553435 [details]
AMO screenshot

When I type something in the AMO search field, a black dash is displayed on the bottom of the input field . I'm able to reproduce it on the latest Nightly build. Is it related to this bug?

--
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110815
Firefox/8.0a1 Fennec/8.0a1
Device: HTC Desire Z
OS: Android 2.3.3
(Assignee)

Comment 17

6 years ago
It looks like the patch on bug 668921 might fix this.
tracking-fennec: 8+ → 7+
(Assignee)

Comment 18

6 years ago
Can anyone still reproduce this since bug 668921 landed?
Appears that the patch for bug 668921 fixed this. Panned around about:home for a few minutes without seeing any painting issue. Tested Aurora and the issue appeared after a short amount of panning.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 20

6 years ago
Verified fixed on: Mozilla /5.0 (Android;Linux armv7l;rv:7.0) Gecko/20110824 Firefox/9.0a1 Fennec/7.0
Device: LG Optimus 2X
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-firefox7: affected → fixed
status-firefox8: affected → fixed
Keywords: verified-aurora, verified-beta
You need to log in before you can comment on or make changes to this bug.