Closed Bug 661939 Opened 9 years ago Closed 9 months ago

[fennec]about:config interface truncated if rendering device doesn't have room for the whole interface

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec-)

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: nhirata, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image screenshot
Mozilla/5.0 (Android; Linux armv71; rv5.0) Gecko/20110527 Firefox/5.0 Fennec/5.0
Device: Thunderbolt
OS: Android 2.2

1. set device to portrait
2. set device to finnish
3. go to about:config

Expected: buttons fit to the screen
Actual: button is cut off
I agree this is a bug, but I don't really see it as a localization/language bug. These terms are well defined and can't be changed any more than the english language terms.

This should in my opinion be handled on the interface rendering side by either truncating the button texts if display device is not big enough to show the whole text, or less optimally by moving the buttons that don't fit onto another row.

I've changed the bug description to reflect this.

Axel: could you please give us your opinion and hopefully someone to direct to the bug.
Summary: [fennec][finnish]about:config will truncate the buttons in portrait view → [fennec]about:config interface truncated if rendering device doesn't have room for the whole interface
Yeah, let's move this over to fennec to get some UX.

We quite generally have the problem that three buttons next to each other don't fit, if I take a summary of other bugs like this.
Assignee: villepohjanheimo+bugzilla → nobody
Component: fi / Finnish → General
Product: Mozilla Localizations → Fennec
QA Contact: finnish.fi → general
Version: unspecified → Trunk
tracking-fennec: --- → ?
dupe of bug 658214?
tracking-fennec: ? → -
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.