Last Comment Bug 662181 - "Deactivate this device" doesn't update UI instantly on slow internet connections
: "Deactivate this device" doesn't update UI instantly on slow internet connect...
Status: VERIFIED FIXED
[verified in services]
: regression, verified-aurora, verified-beta
Product: Cloud Services
Classification: Client Software
Component: Firefox Sync: Backend (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla7
Assigned To: Philipp von Weitershausen [:philikon]
:
Mentors:
Depends on:
Blocks: 565430
  Show dependency treegraph
 
Reported: 2011-06-05 12:59 PDT by Philipp von Weitershausen [:philikon]
Modified: 2013-12-27 14:32 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
v1 (2.55 KB, patch)
2011-06-05 14:48 PDT, Philipp von Weitershausen [:philikon]
rnewman: review+
christian: approval‑mozilla‑aurora+
christian: approval‑mozilla‑beta+
Details | Diff | Review

Description Philipp von Weitershausen [:philikon] 2011-06-05 12:59:59 PDT
This is a regression from bug 565430: we now send requests to the server to clean up any client specific data, but we wait for those requests to come through to clear anything else, including the UI. That means with a laggy internet connection the UI doesn't update instantly and the user is perplexed (I was!).

We should send the appropriate notifications at the top of Service.startOver() so that the UI is updated instantly.
Comment 1 Philipp von Weitershausen [:philikon] 2011-06-05 14:48:40 PDT
Created attachment 537480 [details] [diff] [review]
v1
Comment 2 Richard Newman [:rnewman] 2011-06-06 11:19:04 PDT
Comment on attachment 537480 [details] [diff] [review]
v1

Looks good to me!
Comment 3 Philipp von Weitershausen [:philikon] 2011-06-06 11:27:24 PDT
Justification for approval: bug 565430 introduced a regression and the patch is pretty low risk.
Comment 4 Philipp von Weitershausen [:philikon] 2011-06-06 11:39:58 PDT
http://hg.mozilla.org/services/services-central/rev/874ac197d206
Comment 5 christian 2011-06-06 17:52:32 PDT
(In reply to comment #4)
> http://hg.mozilla.org/services/services-central/rev/874ac197d206

This doesn't look to be the patch in this bug...was this actually fixed or was this bug marked by mistake?
Comment 6 christian 2011-06-06 17:53:29 PDT
Comment on attachment 537480 [details] [diff] [review]
v1

Please land this ASAP, and as long as you are confident enough in the patch for it to be in a RC build.
Comment 7 christian 2011-06-06 18:05:43 PDT
(In reply to comment #6)
> Comment on attachment 537480 [details] [diff] [review] [review]
> v1
> 
> Please land this ASAP, and as long as you are confident enough in the patch
> for it to be in a RC build.

To be more specific, we need this in by tomorrow, 2011-06-07 @ 2:00 pm PDT for mozilla-beta.
Comment 8 Richard Newman [:rnewman] 2011-06-06 19:18:09 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > http://hg.mozilla.org/services/services-central/rev/874ac197d206
> 
> This doesn't look to be the patch in this bug...was this actually fixed or
> was this bug marked by mistake?

Looks like it should be

http://hg.mozilla.org/services/services-central/rev/695a05d90784
Comment 9 Richard Newman [:rnewman] 2011-06-06 19:20:07 PDT
874ac was the parent of that changeset; I think Philipp just copied the wrong one. If he doesn't respond to my IRC ping soonish, I'll go ahead and land this on Aurora.

Christian, does this need to land anywhere else for it to satisfy the requested flags? Not sure of the process.
Comment 10 christian 2011-06-06 19:27:09 PDT
We granted approval on releases/mozilla-beta as well, please land there too.
Comment 11 Richard Newman [:rnewman] 2011-06-06 19:28:23 PDT
Transplanted to Aurora:

http://hg.mozilla.org/releases/mozilla-aurora/rev/8647efd8e1c7
Comment 12 Richard Newman [:rnewman] 2011-06-06 19:38:56 PDT
I'm about half-way done with the beta transplant (just wrestling hg). Will finish after I take the dog for a walk.
Comment 13 Richard Newman [:rnewman] 2011-06-06 21:29:33 PDT
Transplanted to mozilla-beta:

http://hg.mozilla.org/releases/mozilla-beta/rev/9d2108905529

(Carries with it the clusterURL check that didn't make it to beta yet. That's super, super safe, so I included it.)

I have set status-firefox[56] to "fixed", which I understand to be the correct action. Please change that and enlighten me if I'm wrong! 

The only place this now isn't is mozilla-central. When we land this, or merge s-c after QA, we'll resolve this bug.
Comment 14 Richard Newman [:rnewman] 2011-06-06 22:53:43 PDT
... and a bustage fix on mozilla-beta. I am ashamed.

http://hg.mozilla.org/releases/mozilla-beta/rev/065b5f7e37c1
Comment 15 Tracy Walker [:tracy] 2011-06-07 12:15:50 PDT
Verified in aurora nightly of 20110607.  will verify in beta when it's built next and in s-c on next train there.
Comment 16 Asa Dotzler [:asa] 2011-06-07 15:03:55 PDT
not going to continue tracking for 5.
Comment 17 Tony Chung [:tchung] 2011-06-13 11:10:53 PDT
Need testing on Fennec for beta and aurora branch also.
Comment 18 Tracy Walker [:tracy] 2011-06-14 09:12:27 PDT
verified with latest s-c builds
Comment 19 Tony Chung [:tchung] 2011-06-14 11:40:30 PDT
(In reply to comment #17)
> Need testing on Fennec for beta and aurora branch also.

Verified on fennec for aurora and beta branches.

Mozilla/5.0 (Android; Linux armv71; rv:6.0a2) Gecko/20110613 Firefox/6.0a2 Fennec/6.0a2
Mozilla/5.0 (Android; Linux armv71; rv:5.0) Gecko/20110613 Firefox/5.0 Fennec/5.0
Comment 20 Philipp von Weitershausen [:philikon] 2011-06-15 02:29:26 PDT
http://hg.mozilla.org/mozilla-central/rev/695a05d90784

Note You need to log in before you can comment on or make changes to this bug.