Last Comment Bug 662266 - Tabs are not re-arranged when closing a tab in an expanded group
: Tabs are not re-arranged when closing a tab in an expanded group
Status: VERIFIED FIXED
: regression
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 7
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on: 610208
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 06:55 PDT by Tim Taubert [:ttaubert]
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
mounir: in‑testsuite+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v1 (4.02 KB, patch)
2011-06-06 07:06 PDT, Tim Taubert [:ttaubert]
dietrich: review+
raymond: feedback+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] 2011-06-06 06:55:54 PDT
To reproduce, the closed tab must not be the currently selected tab. Regressed since bug 610208 landed.
Comment 1 Tim Taubert [:ttaubert] 2011-06-06 07:06:12 PDT
Created attachment 537550 [details] [diff] [review]
patch v1
Comment 2 Tim Taubert [:ttaubert] 2011-06-06 12:03:53 PDT
Comment on attachment 537550 [details] [diff] [review]
patch v1

Passed try:

http://tbpl.mozilla.org/?tree=Try&pusher=tim.taubert@gmx.de&rev=3de765d80702
Comment 3 Raymond Lee [:raymondlee] 2011-06-06 20:31:50 PDT
Comment on attachment 537550 [details] [diff] [review]
patch v1

Looks good!
Comment 4 Dietrich Ayala (:dietrich) 2011-06-16 06:08:26 PDT
Comment on attachment 537550 [details] [diff] [review]
patch v1

Review of attachment 537550 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 6 Mounir Lamouri (:mounir) 2011-06-18 09:36:48 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/88f04e97f00c
Comment 7 George Carstoiu 2011-06-20 06:57:13 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110620 Firefox/7.0a1

Verified on Ubuntu 11.04 x86, WinXP, Win7 x86, Mac OS X 10.6 using the following steps:
 1. Create several tabs
 2. Enter Panorama 
 3. Minimize group until you get a stack
 4. Press expand button
 5. Close one of the tabs

Issue is no longer reproducible - setting status to Verified.

Note You need to log in before you can comment on or make changes to this bug.