Closed Bug 662302 Opened 10 years ago Closed 10 years ago

Droid Pro: Unable to pan back to content window with 3 columns of tabs open

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Android
defect

Tracking

(fennec-)

VERIFIED FIXED
Firefox 7
Tracking Status
fennec - ---

People

(Reporter: tchung, Assigned: mfinkle)

References

Details

Attachments

(3 files)

Attached image Droid Pro tab pane
On a droid pro, if more than 3 columns of tabs are open, i am unable to pan back to the content window.

See screenshot

Repro:
1) install Firefox 4.0.1, droid Pro
2) launch firefox, pan to the left, and open 3 columns worth of tabs
3) Verify unable to pan back to the content window

Expected:
- pan back to content window with open tabs

Actual:
- stays on tab pane.  droid Pro only
can we get this fixed for fennec 6?   this scenario would fail a bft test for this device.
tracking-fennec: --- → ?
Are you sure this is Droid Pro only? I can open 3+ columns of tabs, and am able to scroll the columns between them. To access content, I start my scroll but touching the far right content side. Are you sure you're not just missing that available area?
For example see screenshot, I begin my content scroll to close the sidebar in the available content area
(In reply to comment #3)
> Created attachment 537610 [details]
> HTC Nexus One - screenshot
> 
> For example see screenshot, I begin my content scroll to close the sidebar
> in the available content area

I believe the smaller screen on the Droid Pro means there is no "content" area visible, so you can't pan the sidebar closed.

(In reply to comment #1)
> can we get this fixed for fennec 6?   this scenario would fail a bft test
> for this device.

We should fix this issue, but I don't know how pressing it is for Fx6, since it requires many tabs to be open.
> (In reply to comment #1)
> > can we get this fixed for fennec 6?   this scenario would fail a bft test
> > for this device.
> 
> We should fix this issue, but I don't know how pressing it is for Fx6, since
> it requires many tabs to be open.

yeah, its an edge case of opening 9+ tabs. if its a simple patch with limited regression cases, i vote for taking it.  else, im fine to punt.
not tracking - low priority.
tracking-fennec: ? → -
Reproducible (via Andreea Pod) on other small screen Android based device such as the Motorola Charm:

https://wiki.mozilla.org/images/1/12/Motorola_Charm_1.PNG
https://wiki.mozilla.org/images/1/12/Motorola_Charm_2.PNG
https://wiki.mozilla.org/images/1/12/Motorola_Charm_3.PNG

This should raise a flag for other irregular Android devices with small screens and their browser usability and experiences with Fennec.
Depends on: 651821
Attached patch patchSplinter Review
This patch clamps the scrollbox (sidebar) to never overflow the window width. The result is the user can alway pan away the tab sidebar
Assignee: nobody → mark.finkle
Attachment #541044 - Flags: review?(21)
Comment on attachment 541044 [details] [diff] [review]
patch

As said on IRC, I wonder if using media-queries with a small set of rules can do the trick, but as long as this patch fix the bug that's fine to me.
Attachment #541044 - Flags: review?(21) → review+
Pushed:
http://hg.mozilla.org/mozilla-central/rev/278449a6964d
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 7
Verified Fixed -- Tested on a (Motorola Droid Pro via Device Anywhere)

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 Fennec/7.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.