Last Comment Bug 662946 - Remove a bunch of headers from INSTALLED_HEADERS, making changes necessary to do so
: Remove a bunch of headers from INSTALLED_HEADERS, making changes necessary to...
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
Depends on:
Blocks: 554088
  Show dependency treegraph
 
Reported: 2011-06-08 15:23 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-01-07 07:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (23.23 KB, patch)
2011-06-08 15:23 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
jimb: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-08 15:23:05 PDT
Created attachment 538125 [details] [diff] [review]
Patch

Inspired by bug 662231, I went on a mini-rampage pruning INSTALLED_HEADERS by almost 20%.  Some of the entries in the list can be flat-out removed with no other changes.  Others need a little trimming in Mozilla code to remove them.  Others need (dead) callers to be killed in order to remove then-pointless inclusions.  Some need some forward-declares to avoid inclusions.  But anyway, all the removals here were pretty easy, and they required no deep surgery to disconnect XPConnect and jsobj.h or jsscope.h or jscntxt.h or anything similarly awful.  I'll leave that for other people and other times.

Try-building has not yet given this a stamp of approval:

http://tbpl.mozilla.org/?tree=Try&rev=32b4723ce26c

But a local build has, so I'm posting this in anticipation of being able to r? it shortly.
Comment 1 Jim Blandy :jimb 2011-06-10 14:22:37 PDT
Hi, Jeff. I'll be able to review this and your other patches on Monday, but for today I have some Debugger stuff I'm really hoping to wrap up before Jason gets back from vacation.
Comment 2 Jim Blandy :jimb 2011-06-14 11:49:52 PDT
Comment on attachment 538125 [details] [diff] [review]
Patch

Review of attachment 538125 [details] [diff] [review]:
-----------------------------------------------------------------

r+, including parts I'm not a reviewer for, since it's dead code.
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-16 13:13:31 PDT
http://hg.mozilla.org/tracemonkey/rev/ce077af8195c
Comment 4 Franck 2011-06-20 03:28:16 PDT
Note that the bug 615621 is probably related to this one.
Comment 5 Chris Leary [:cdleary] (not checking bugmail) 2011-06-20 17:03:59 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/ce077af8195c

Note You need to log in before you can comment on or make changes to this bug.