The default bug view has changed. See this FAQ.

Recursive "Verify new product details" page when attempting to move multiple bugs to another product

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Nicholas Herring, Assigned: Frédéric Buclin)

Tracking

({regression})

Bugzilla 4.0
regression
Bug Flags:
approval +
blocking4.2 +
approval4.0 +
blocking4.0.2 +
testcase +

Details

(URL)

Attachments

(1 attachment)

915 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.77 Safari/534.24
Build Identifier: Bugzilla 4.0

I have tried this on a private server and landfill. It would seem if you attempt to move multiple bugs to another product the "Verify version" page will never accept your selections

Reproducible: Always

Steps to Reproduce:
1. Get a buglist of at least 2 bugs. 
2. Use Change multiple bugs at once.
3. Select 2 bugs.
4. Change their product from their current.
5. At "Verify version" page select proper information
6. Click commit

Actual Results:  
The "Verify version" page will reload asking for the same information again. Interesting note: the "Verify Bug Group" will disappear on the second render.

Expected Results:  
The Commit button should should process bug activity for selected bugs.

Move a single bug works fine from both the bug page and selecting only one bug with "Change several bugs at once".
(Assignee)

Comment 1

6 years ago
I can reproduce in both 4.0.1 and 4.1.2. Didn't test with 3.6.5 yet.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking4.2+
Flags: blocking4.0.2+
Keywords: regression
OS: Other → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 4.0
Version: unspecified → 4.0
(Assignee)

Comment 2

6 years ago
3.6.5 is not affected.
(Assignee)

Comment 3

6 years ago
Created attachment 538615 [details] [diff] [review]
patch, v1

We have to copy the hash to not alter data used for subsequent bugs when calling set_all() in a loop in process_bug.cgi. The problem here was that some fields, including the component, version and target milestone, were deleted when calling set_all(), and so the subsequent bugs in a mass-change had no values for these fields, triggering the confirmation page again and again.
Assignee: create-and-change → LpSolit
Status: NEW → ASSIGNED
Attachment #538615 - Flags: review?(mkanat)
(Assignee)

Updated

6 years ago
Depends on: 556407
Summary: Recursive "Verify version" page when attempting to move multiple bugs to another product → Recursive "Verify new product details" page when attempting to move multiple bugs to another product

Comment 4

6 years ago
Comment on attachment 538615 [details] [diff] [review]
patch, v1

Looks good to me. :-)
Attachment #538615 - Flags: review?(mkanat) → review+

Updated

6 years ago
Flags: approval4.0+
Flags: approval+
(Assignee)

Comment 5

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Bug.pm
Committed revision 7836.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Bug.pm
Committed revision 7603.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: testcase?
Resolution: --- → FIXED

Comment 6

6 years ago
I applied this patch on my clean 4.0.1 installation, and the problem still remains. (confirm page keeps coming up)
Does it depend on other fixes since 4.0.1 stable?

Comment 7

6 years ago
(In reply to comment #6)
> I applied this patch on my clean 4.0.1 installation, and the problem still
> remains. (confirm page keeps coming up)
> Does it depend on other fixes since 4.0.1 stable?

D'Oh.  The confirm page had unselected fields, so it kept repeating.  Works fine if I actually select a value for those fields.

Comment 8

6 years ago
(In reply to comment #7)
> D'Oh.  The confirm page had unselected fields, so it kept repeating.  Works
> fine if I actually select a value for those fields.

  You're welcome to file a bug for the fact that it can be hard to notice that, and that we should validate it with JS.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 676416
(Assignee)

Updated

6 years ago
Flags: testcase? → testcase+
You need to log in before you can comment on or make changes to this bug.