Browser freezes/crashes after using link to non-existent local/ftp location

VERIFIED DUPLICATE of bug 69134

Status

()

Core
Networking: File
--
critical
VERIFIED DUPLICATE of bug 69134
18 years ago
10 years ago

People

(Reporter: Val Sharp, Assigned: dougt)

Tracking

({hang})

Trunk
mozilla0.9
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2001010901 & 2001012020

Clicking on a link <a href="links"> or <a href="links/"> where 'links' doesn't 
exist, can cause the browser to freeze/not respond.

A 'Reload' after clicking on the link will almost always cause it to freeze.


However, sometimes the browser will crash, as in here in M0.7 (though I haven't 
been able to isolate the exact circumstances to reproduce it):

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 016f:60cd4f29.
Registers:
EAX=00000000 CS=016f EIP=60cd4f29 EFLGS=00010246
EBX=0068f920 SS=0177 ESP=0068f8bc EBP=0068f8dc
ECX=00660069 DS=0177 ESI=0068f90c FS=4d0f
EDX=00000000 ES=0177 EDI=ffcc7fe9 GS=0000
Bytes at CS:EIP:
8b 01 ff 50 14 85 c0 74 07 8b 06 89 46 0c eb e3 
Stack dump:
0068f90c 00000003 00000000 0068f90c 60cd4b01 00cc0a78 0068f90c ffcc7fe9 0068f924 
60ce3a6c 0003801d 0068f920 00cc0aa0 00cc0a70 60ce2c64 0068f90c

And again:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 016f:60cd4f29.
Registers:
EAX=00000000 CS=016f EIP=60cd4f29 EFLGS=00010246
EBX=0068f920 SS=0177 ESP=0068f8bc EBP=0068f8dc
ECX=ffff0006 DS=0177 ESI=0068f90c FS=44ff
EDX=00000000 ES=0177 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 01 ff 50 14 85 c0 74 07 8b 06 89 46 0c eb e3 
Stack dump:
0068f90c 00000003 00000000 0068f90c 60cd4b01 00d511f8 0068f90c 00000000 0068f924 
60ce3a6c 00427320 0068f920 00d51220 00d511f0 60ce2c64 0068f90c 


And in 2001012020:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 016f:60d34db3.
Registers:
EAX=00000000 CS=016f EIP=60d34db3 EFLGS=00010246
EBX=0068f924 SS=0177 ESP=0068f8c0 EBP=0068f8e0
ECX=00000041 DS=0177 ESI=0068f910 FS=4577
EDX=00000000 ES=0177 EDI=ffffff88 GS=0000
Bytes at CS:EIP:
8b 01 ff 50 14 85 c0 74 07 8b 06 89 46 0c eb e3 
Stack dump:
0068f910 00000003 00000000 0068f910 60d34b44 00db7428 0068f910 ffffff88 0068f928 
60d43a8f 00377fc1 0068f924 00db7450 00db7420 60d42c87 0068f910 


Also, a couple of times after freezing in 2001012020, I've had a 'Fatal 
Exception' occurring at 016f:BFFAADOB when trying to end task with ctrl+alt+del.


Reproducible: Sometimes

Steps to Reproduce:
The attachment contains the link <a href="links">
Try clicking the link.
If that doesn't freeze the browser, try a 'Reload' (or two) as well.
(Reporter)

Comment 1

18 years ago
Created attachment 23283 [details]
testcase - link causing browser to freeze
(Reporter)

Comment 2

18 years ago
OK, just discovered it doesn't work online.

Attachment needs to be downloaded and tried offline.

Comment 3

18 years ago
Could this be related in any way to bug 18007?

Comment 4

18 years ago
Build ID: 2001012205
OS: Win NT 4
Platform: PC

Mozilla seems to load a nonexisting local file rather than give an error message
when clicking the link in the attachment after downloading it. When I click
reload it freezes.

Comment 5

18 years ago
Created attachment 23317 [details]
a testcase that would work online

Comment 6

18 years ago
no freeze here on NT mozilla build 012304

Comment 7

18 years ago
reporter: could you get a talkback build and submit a report? with that stack
trace, we can find out if this is perhaps a dupe or a new bug.

btw, i was not able to crash 20001012304 win98

Comment 8

18 years ago
Confirmed on 2001012404 (Win 98) using the first attachment (23283) after saving
locally.

After clicking the link in that attachment Mozilla froze.

Reassigning to Networking: File, confirming, and adding "hang" keyword.
Component: Browser-General → Networking: File
Keywords: hang

Comment 9

18 years ago
forgot to confirm and reassign.
Assignee: asa → dougt
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → tever

Comment 10

18 years ago
*** Bug 66414 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
I did a little more testing on this bug and have some new information to report:
clicking on the "non-existent" link will either do nothing, freeze mozilla, or
crash mozilla.  Distribution of these events is random and does not appear to
follow any patterns.  I attempted to run a talkback build, however, I was unable
to get the QFA component to initialize on my computer.  A test from someone who
has talkback running would be good.

Comment 12

18 years ago
May be related to bug 38643...
(Assignee)

Comment 13

18 years ago
I tried both test cases with a recent mozilla build and could not reproduce.

Comment 14

18 years ago
Created attachment 25148 [details]
a windows-specific test case

Comment 15

18 years ago
I suspect this is a windows-specific bug.

I attached a third test case because the second one does not hang for me. It
appears to me that it doesnt hang unless you have the drive letter in there,
such as file:///C|some/path/that/isnt/there

Also, note bug 63048 which tracks the lack of an error-page for local
non-existant files. It makes mention of symptoms of this bug

Comment 16

18 years ago
Looks like the same problem as for bug 63642
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Keywords: nsbeta1, qawanted
(Assignee)

Comment 17

18 years ago
*** Bug 63642 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

18 years ago
*** Bug 64483 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Summary: Browser freezes/crashes after using link to non-existent directory. → Browser freezes/crashes after using link to non-existent location

Updated

18 years ago
Summary: Browser freezes/crashes after using link to non-existent location → Browser freezes/crashes after using link to non-existent local/ftp location
(Assignee)

Comment 19

18 years ago
*** Bug 66687 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

18 years ago
*** Bug 72026 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

18 years ago
Marking this bug as a dup.  Please check out the patch that is attached to that
bug, or better yet update your mozilla/netwerk/ directory and verify that this
problem does not exist.

I could not reproduce ince this appears to only happen on win98??

*** This bug has been marked as a duplicate of 69134 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 22

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.