Closed Bug 18007 Opened 20 years ago Closed 19 years ago

DNS: FTP hostname error

Categories

(Core :: Networking: FTP, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: tever, Assigned: mscott)

References

Details

(Whiteboard: [nsbeta2-][nsbeta3-][rtm-])

Overview Description:  Browser not handling invalid ftp sites properly.

Steps to Reproduce:
1.)  Enter invalid ftp site in location window.  Try for example ftp://ftp.yyy

Actual Results:  Dialog with 'Unknown file type' message appears.  'You are
about to download a file of type application/x-unknown' etc.

Expected Results:  Expect dialog with 'Unable to locate server' message.

Build Date & Platform Bug Found:
 1999110408   Windows NT
Assignee: gagan → valeski
Tom- file FTP bugs to Judson. Thx.
Assignee: valeski → law
this is actually a bill law bug. the unknown content type viewer isn't handing
valid error codes passed bacy on an OnStop().
Blocks: 12834
Summary: invalid Ftp site not handled properly → [DOGFOOD] invalid Ftp site not handled properly
Target Milestone: M12
Whiteboard: [PDT-]
This is an edge case. Putting on PDT- radar.  Porkjockey work to fix.
Status: NEW → ASSIGNED
Target Milestone: M12 → M13
Move to M13 ...
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Priority: P3 → P2
Summary: [DOGFOOD] invalid Ftp site not handled properly → Invalid Ftp site not handled properly
Whiteboard: [PDT-]
Target Milestone: M13 → M14
M14?
Assignee: law → valeski
Status: ASSIGNED → NEW
Depends on: 24435
currently FTP has no way of getting DNS failure info. this is dependent on a
change in the socket transport. Once it can get DNS failure info, a dialog will
automatically be thrown.

note that current behavior is that nothing is done. no dialogs are thrown.
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
good to get for beta1 or at least give release note recognition so
a user might know what the heck is going on...  the message
they would get under current behavior is know where near
the error...
Keywords: beta1
PDT-
Whiteboard: [PDT-]
*** Bug 26365 has been marked as a duplicate of this bug. ***
*** Bug 27464 has been marked as a duplicate of this bug. ***
*** Bug 27979 has been marked as a duplicate of this bug. ***
Moving to M16.
Target Milestone: M15 → M16
Keywords: beta1beta2
Whiteboard: [PDT-]
Whiteboard: 1d
Keywords: nsbeta2
finally in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
this has been backed out. it breaks mail/news on linux because of a race
condition when sync unix dns is envoked.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 10733
Need 17033 work done first. Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: 1d → [nsbeta2+]1d
M16 has been out for a while now, these bugs target milestones need to be 
updated.
*** Bug 40913 has been marked as a duplicate of this bug. ***
Per PDT mtg, moving from [nsbeta2+] to [nsbeta2-].  gagan believes this is a 
dup.
Whiteboard: [nsbeta2+]1d → [nsbeta2-]1d
robert-- welcome to necko!
Assignee: valeski → rjc
Status: REOPENED → NEW
Adding nsbeta3 keyword. We need to bring up SOME dialog if the ftp site isn't valid.
Keywords: nsbeta3
[nsbeta3-] unless Robert has additional info on this. Sounds like we've lived 
with it for a while now.
Whiteboard: [nsbeta2-]1d → [nsbeta2-][nsbeta3-]
Yes, WE'VE lived with it because mozilla is still in a "alpha/beta/unfinished"
state. However, this is going to confuse the HELL out of people like my parents.
There's no way that we should have this kind of bug in a release product that
average (dumb) users are going to be using.

Adding rtm keyword because it would be horrible to not fix this before RTM.
Keywords: rtm
Jud, what's the story with this bug?  Were the changes ever made to the socket 
transport to propogate DNS failures up?

Truthfully, it seems like this type of error dialog should be displayed by the 
docshell.  mscott?
Assignee: rjc → mscott
Whiteboard: [nsbeta2-][nsbeta3-] → [nsbeta2-][nsbeta3-][rtm-]
marking rtm-. As dveditz said we've lived with this for a while and it's not one 
of the highest priority bugs.
I would add to the subject: "and for any other error". If the ftp site does
exist but that your access is denied, no message is displayed either and you
won't have any clue why you don't have access.

Target Milestone should be updated.
Severity should be upgraded to major.

<grain of salt>
The fact that we've lived with a bug till now is not a good excuse not to try to
solve it.
</grain of salt>
*** Bug 57895 has been marked as a duplicate of this bug. ***
Patrick: The "any other error" is bug 25014:
"[RFE] Inaccessible file/directory not handled??"
I just have to say this..
This bug is about basic user feedback. Or rather... the lack of it. That this is
still missing makes mozilla look so stupid i don't know whether to cry or laugh.
Same goes for bug 25014. Error handling routines and user feedback are primary
functions in any application. The fact that this bug is old does NOT mean it is
acceptable - by far! Lack of user feedback is amateurish at best. I consider
18007 and 25014 a bloody disgrace really. Things like these make me ashamed of
recommending mozilla to anyone.
R.K.Aa: Mozilla is not even close to release yet, so not wanting to recommend it
to anyone is not that much of an issue! :-)

Nominating for mozilla1.0 based on above comments.
Keywords: mozilla1.0
Nominating for mozilla0.9!
Since it seems to be an important (large, difficult) feature, it has to be in
the build as long as possible before release to be able to track bugs for a
longer time!

BTW, the status NEW is a bit lazy, isn't it?
Hixie darling: If you want to exercise some goodwill, you may read my previous
comment again, replacing occurances of "mozilla" with "netscape 6".
"Target Milestone M16"? Sheesh..
*** Bug 66310 has been marked as a duplicate of this bug. ***
I'm upgrading this to a mostfreq based on the number of times I've run into
people complainig about this.
Keywords: mostfreq
hi folks,

i am bug 66310, and, as i'm not certain to do with the resolver's question (have
you ever actually seen it crash because of this), the 20010122 or so build i
picked up this morning (jan 23, 2001) crashed while i was confirming the bug. i
had 2 instances of zilla open and was spamming both with bad ftp urls, and it
blew up. i tried that again, and was not able to reproduce it.
Can someone please update this bug with a sane target milestone, as it is now on 
the mostfreq list? Cheers :-)

Gerv
Unsetting target milestone - M16 is long past.

Gerv
Target Milestone: M16 → ---
WORKSFORME 2001-03-29 Win95.

Gerv
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WORKSFORME
Is this really WFM? I have this problem in mozilla 0.8.
This WORKSFORME on Linux build 2001040216.
verified wfm - WinNT 2001043004
Status: RESOLVED → VERIFIED
Component: Networking → Networking: FTP
Summary: Invalid Ftp site not handled properly → DNS: FTP hostname error
You need to log in before you can comment on or make changes to this bug.