Closed Bug 663584 Opened 8 years ago Closed 7 years ago

Intermittent timeout in browser/base/content/test/tabview/browser_tabview_bug610208.js | application timed out after 330 seconds with no output

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dcamp, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 obsolete file)

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1307751473.1307752876.26634.gz
Rev3 WINNT 5.1 mozilla-aurora opt test mochitest-other on 2011/06/10 17:17:53

EST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testResizeGroup: tabs changed their size
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testRemoveWhileStacked: group is not stacked
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testRemoveWhileStacked: group is not stacked
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testRemoveWhileStacked: tabs did not change their size
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testExpandedMode: group is stacked
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testExpandedMode: tabs did not change their size
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | testExpandedMode: tabs did not change their size
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug610208.js | application timed out after 330 seconds with no output
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Version: unspecified → Trunk
Attached patch patch v1 (obsolete) — Splinter Review
Added waitForFocus(finish) because that hangs intermittently when having multiple windows.
Attachment #538674 - Flags: review?(ehsan)
browser-test.js already calls waitForFocus between tests.
Attachment #538674 - Flags: review?(ehsan)
(In reply to comment #2)
> browser-test.js already calls waitForFocus between tests.

I should stop using waitForFocus(finish) because I just remembered when it is actually useful to do this: when using ss.setBrowserState() and having multiple windows (see bug 599253 comment #389 - so it's not even useful ATM).

So the hunt is on again for the cause of this intermittent timeout.
Assignee: tim.taubert → nobody
Blocks: 660175
Status: ASSIGNED → NEW
Attachment #538674 - Attachment is obsolete: true
Adding intermittent test failures to new meta bug.

(bugspam)
Blocks: 665844
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.