Last Comment Bug 663630 - Remove unused places UI perf tests
: Remove unused places UI perf tests
Status: VERIFIED FIXED
[fixed-in-places]
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 7
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 636551 726491
  Show dependency treegraph
 
Reported: 2011-06-11 08:29 PDT by Dão Gottwald [:dao]
Modified: 2012-03-16 18:40 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (21.08 KB, patch)
2011-06-11 08:29 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Review
rm (44.74 KB, patch)
2011-06-13 02:48 PDT, Dão Gottwald [:dao]
mak77: review+
Details | Diff | Review
followup: fix makefiles.sh (1.07 KB, patch)
2011-07-11 10:49 PDT, Daniel Holbert [:dholbert]
mak77: review+
Details | Diff | Review

Description Dão Gottwald [:dao] 2011-06-11 08:29:52 PDT
Created attachment 538700 [details] [diff] [review]
patch
Comment 1 Shawn Wilsher :sdwilsh 2011-06-11 15:30:35 PDT
I don't think we even look at these, so we could probably nuke them.
Comment 2 Dão Gottwald [:dao] 2011-06-11 22:26:20 PDT
perf_large_delete.xul too?
Comment 3 Shawn Wilsher :sdwilsh 2011-06-12 08:59:47 PDT
(In reply to comment #2)
> perf_large_delete.xul too?
Check with mak, but I'd lean to yes at this point.
Comment 4 Dão Gottwald [:dao] 2011-06-13 02:48:49 PDT
Created attachment 538841 [details] [diff] [review]
rm
Comment 5 Marco Bonardo [::mak] 2011-06-17 06:33:12 PDT
Comment on attachment 538841 [details] [diff] [review]
rm

Yes, I was initially against removing these tests because we didn't have enough other tests leveraging that UI stuff, but now all that stuff is touched elsewhere, so it's ok to kill the tests folder.
Comment 6 Marco Bonardo [::mak] 2011-06-17 06:37:30 PDT
I'll land this on Places shortly.
Comment 7 Marco Bonardo [::mak] 2011-06-17 07:41:55 PDT
http://hg.mozilla.org/projects/places/rev/5378269494af
Comment 8 Marco Bonardo [::mak] 2011-06-18 04:44:40 PDT
http://hg.mozilla.org/mozilla-central/rev/5378269494af
Comment 9 George Carstoiu 2011-06-28 05:51:21 PDT
 Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110627 Firefox/7.0a1

Verified that folder was removed from the repository. 

Set status to Verified Fixed.
Comment 10 Daniel Holbert [:dholbert] 2011-07-11 10:46:56 PDT
Now we get this buildspam:
> can't read browser/components/places/tests/perf/Makefile.in: No such file or directory

This bug was missing an update to browser/makefiles.sh (which references that now-deleted makefile)
Comment 11 Daniel Holbert [:dholbert] 2011-07-11 10:49:03 PDT
Created attachment 545208 [details] [diff] [review]
followup: fix makefiles.sh

This fixes the buildspam noted in the previous comment.
Comment 12 Marco Bonardo [::mak] 2011-07-11 13:59:14 PDT
Comment on attachment 545208 [details] [diff] [review]
followup: fix makefiles.sh

Review of attachment 545208 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Comment 13 Daniel Holbert [:dholbert] 2011-07-12 12:59:52 PDT
Landed followup on m-i:
 http://hg.mozilla.org/integration/mozilla-inbound/rev/64c70dce2ee7
Comment 14 :Ehsan Akhgari (out sick) 2011-07-13 09:01:14 PDT
http://hg.mozilla.org/mozilla-central/rev/64c70dce2ee7

Note You need to log in before you can comment on or make changes to this bug.