Closed Bug 663687 Opened 9 years ago Closed 9 years ago

Manually moving mails to a local folder - the folder becomes invisible and the mail info becomes small and blurred

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows 7
defect
Not set

Tracking

(blocking-thunderbird5.0 beta2+, thunderbird5.0 beta2-fixed, thunderbird6 fixed)

RESOLVED FIXED
Thunderbird 7.0
Tracking Status
blocking-thunderbird5.0 --- beta2+
thunderbird5.0 --- beta2-fixed
thunderbird6 --- fixed

People

(Reporter: mploug, Assigned: bwinton)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET4.0C; .NET4.0E)
Build Identifier: 5.0b1

When I manually move one og more mails from the inbox to a local folder the folder becomes invisible and the mail info becmes small and blurred.
See image on the URL above.

Reproducible: Always

Steps to Reproduce:
1.Drag a mail from the inbox to a local folder
2. When the mail is above (hovered) the local folder the folder becomes invisible and the mail info becomes small and blurred.
3.

Actual Results:  
The mail is moved ok, but it is hard to see if you hit the right folder and if it is the right mail you are moving.

Expected Results:  
The local folder should be visible all the time and the mail info sholud not become small and blurred.
You have the same issue in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode)?
this may be specific to windows, but it's definitely an issue, and doesn't have to do with extensions or non-default themes. It's possibly a dup as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have just tried in safe mode. It is not quite so bad but still - it is not pretty. Yes, maybe it is a Windows thing.
The problem is worst in the Thunderbird beta 5.0b1.
The folder (name) does not become invisible in 
Thunderbird 3.1.10.
Confirmed, only happens on Windows Vista / 7, doesn't happen on XP.

Andreas/Richard, could you take a look at this as I think it is a blocker to release, as it doesn't look good to the user.
blocking-thunderbird5.0: --- → beta2+
Assignee: nobody → bwinton
For this patch, I've only made the folder name stay in black for a couple of reasons.

1) It's a small change so that we might be able to take it in the next 5.0 beta.

2) The cursor changes when you're not over a dropable element, so highlighting the element you're dropping it on isn't critical.

3) You should be able to see the things you're dragging, because they will still be selected in the thread pane.

If we decide we want more after this, we can open a new bug, or attach a better patch later.

Thanks,
Blake.
Attachment #540507 - Flags: review?(mbanner)
Attachment #540507 - Flags: approval-thunderbird5.0?
Attachment #540507 - Flags: approval-comm-aurora?
Comment on attachment 540507 [details] [diff] [review]
A patch to make the folder more visible.

Ok, this is at least better, good enough for b2. Let's file a follow-up to improve the highlights more and we can consider if we're good enough for final at the same time.
Attachment #540507 - Flags: review?(mbanner)
Attachment #540507 - Flags: review+
Attachment #540507 - Flags: approval-thunderbird5.0?
Attachment #540507 - Flags: approval-thunderbird5.0+
Attachment #540507 - Flags: approval-comm-aurora?
Attachment #540507 - Flags: approval-comm-aurora+
Checked into Miramar: http://hg.mozilla.org/releases/comm-miramar/rev/8cf6df3699b6
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0
You need to log in before you can comment on or make changes to this bug.