Asteroids Benchmark is slower in Firefox than Chrome

RESOLVED DUPLICATE of bug 935304

Status

()

defect
RESOLVED DUPLICATE of bug 935304
8 years ago
4 years ago

People

(Reporter: dvander, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

()

This gets 90fps on Chromium and 21fps on my Linux box, using Firefox 4. Reported by someone on IRC who gets the same results.

I'm not sure if this is related to bug 597377.
It's the same url, but clearly a separate issue... esp. if you think it's gated on JS perf.
Just noticed this on current version of FF 9.
Possibly a red herring, restarted browser, and problem was less evident.  
May have been seeing the effects of another performance bug.
I get 64fps in Nightly and 68fps in Chromium.
Assignee: general → nobody
Firefox is still about 2x slower than Chrome on OS X:

Nightly 39:
Benchmark Score: 1480
Average FPS: 31

Chrome 41:
Benchmark Score: 3221
Average FPS: 68
Keywords: perf
OS: Linux → All
Hardware: x86_64 → All
Summary: Asteroids Benchmark is Slow → Asteroids Benchmark is slower in Firefox than Chrome
The URL says it's been replaced by CanvasMark [0] and I am unsure this is *only* about JS, as the "canvas" name suggests. If there's no meta-bug about CanvasMark already, should there be one?

[0] http://www.kevs3d.co.uk/dev/canvasmark/
Bug 935304 is the meta bug for CanvasMark. I'm going to close this bug as a dupe because the CanvasMark meta bug already has dependencies for the individual test cases.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935304
You need to log in before you can comment on or make changes to this bug.