Bug 579390 (WebJSPerf)

[meta] JM: Further optimizations for the web

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
4 months ago

People

(Reporter: dmandelin, Unassigned)

Tracking

(Depends on: 43 bugs, {meta})

Firefox Tracking Flags

(blocking-kilimanjaro:-)

Details

(Reporter)

Description

9 years ago
This is a meta bug for optimizations that will help JM do stuff on the web faster. We have to prioritize benchmark wins for the immediate future, so this stuff is strictly lower priority than the bugs hung off JaegerSpeed for now.
(Reporter)

Updated

9 years ago
Alias: JaegerWebSpeed
(Reporter)

Updated

9 years ago
Depends on: 579400
Isn't this antithetical to the sentiment in, for example, bug 410460 (that things shouldn't be done just to improve benchmark performance)?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Isn't this antithetical to the sentiment in, for example, bug 410460 (that
> things shouldn't be done just to improve benchmark performance)?

If we are not fast on the JS benchmarks, then too many people will think we are slow. The benchmark wins will help many real programs, too--all the bugs I filed speed up things that people reasonably would do in their JS programs. It's just a matter of what order we do the optimizations in. Once our scores are good we don't have to worry about them so much any more and can focus on cooler things like WebGL Quake.

Updated

9 years ago
Depends on: 581747
(Reporter)

Updated

9 years ago
Depends on: 580018
(Reporter)

Updated

9 years ago
Depends on: 585497
(Reporter)

Updated

9 years ago
Depends on: 586359
(Reporter)

Updated

9 years ago
Depends on: 586996
(Reporter)

Updated

9 years ago
Depends on: 589422
(Reporter)

Updated

9 years ago
Depends on: 590041
(Reporter)

Updated

9 years ago
Depends on: 590379
(Reporter)

Updated

9 years ago
Depends on: 590380

Comment 3

9 years ago
Nicely Put David and absolute correct :) 

http://xplsv.com/prods/demos/xplsv_orsotheysay/ <- this here is also some of the synthetic Javascript Engine things after Jsnes that people think should run @ higher FPS as it does in Chrome, though it was designed for Chrome in mind :)
Depends on: 591972
(Reporter)

Updated

9 years ago
Depends on: 592153
(Reporter)

Updated

9 years ago
Depends on: 593801
(Reporter)

Updated

9 years ago
Depends on: 597037
(Reporter)

Updated

9 years ago
Depends on: 514765
Depends on: 601988
(Reporter)

Updated

9 years ago
Depends on: 605426
Depends on: 610296
(Reporter)

Updated

9 years ago
Depends on: 611423
(Reporter)

Updated

9 years ago
Depends on: 613967
(Reporter)

Updated

8 years ago
Depends on: 615337
(Reporter)

Updated

8 years ago
Depends on: 619761
(Reporter)

Updated

8 years ago
Depends on: 624298
(Reporter)

Updated

8 years ago
Depends on: 624299
(Reporter)

Updated

8 years ago
Depends on: 626021
Depends on: 627857
No longer depends on: 627857
(Reporter)

Updated

8 years ago
Depends on: 628073
(Reporter)

Updated

8 years ago
Depends on: 628170
(Reporter)

Updated

8 years ago
Depends on: 629167
(Reporter)

Updated

8 years ago
Depends on: 631911
(Reporter)

Updated

8 years ago
Depends on: 636096
(Reporter)

Updated

8 years ago
Depends on: 636755
(Reporter)

Updated

8 years ago
Depends on: 639385
Depends on: 639858
(Reporter)

Updated

8 years ago
Depends on: 643629
(Reporter)

Updated

8 years ago
Depends on: 612993
(Reporter)

Updated

8 years ago
Depends on: 650939
(Reporter)

Updated

8 years ago
Depends on: 648198
(Reporter)

Updated

8 years ago
Depends on: 652346
(Reporter)

Updated

8 years ago
Depends on: 652377
(Reporter)

Updated

8 years ago
Depends on: 653967
(Reporter)

Updated

8 years ago
Depends on: 654190

Updated

8 years ago
Depends on: 658844
(Reporter)

Updated

8 years ago
Depends on: 659577
(Reporter)

Updated

8 years ago
Depends on: 659467
(Reporter)

Updated

8 years ago
Depends on: 661719
Depends on: 662503
(Reporter)

Updated

8 years ago
Depends on: 664655
Depends on: 667096
(Reporter)

Updated

8 years ago
Depends on: 668963
(Reporter)

Updated

8 years ago
Depends on: 671324
(Reporter)

Updated

8 years ago
Depends on: 674343
(Reporter)

Updated

8 years ago
Depends on: 674688
(Reporter)

Updated

8 years ago
Depends on: 675167
(Reporter)

Updated

8 years ago
Depends on: 670493
(Reporter)

Updated

8 years ago
Depends on: 678939
Depends on: 681062
(Reporter)

Updated

8 years ago
Depends on: 688219
(Reporter)

Updated

7 years ago
Depends on: 698017
(Reporter)

Updated

7 years ago
Depends on: 698822
(Reporter)

Updated

7 years ago
Depends on: 703132
(Reporter)

Updated

7 years ago
Depends on: 708641
(Reporter)

Updated

7 years ago
Depends on: 709452
(Reporter)

Updated

7 years ago
Depends on: 713875
(Reporter)

Updated

7 years ago
Depends on: 713813
(Reporter)

Updated

7 years ago
Depends on: 714010
(Reporter)

Updated

7 years ago
Depends on: 714653
(Reporter)

Updated

7 years ago
Depends on: 714369
(Reporter)

Updated

7 years ago
Depends on: 716255
(Reporter)

Updated

7 years ago
Depends on: 717637
(Reporter)

Updated

7 years ago
Depends on: 613398
(Reporter)

Updated

7 years ago
Depends on: 684028
(Reporter)

Updated

7 years ago
Depends on: 729376
(Reporter)

Updated

7 years ago
Alias: JaegerWebSpeed → WebJSPerf
(Reporter)

Updated

7 years ago
Depends on: 731566
(Reporter)

Updated

7 years ago
Depends on: 732621
(Reporter)

Updated

7 years ago
Depends on: 733208
(Reporter)

Updated

7 years ago
Depends on: 734486
(Reporter)

Updated

7 years ago
Depends on: 734100
(Reporter)

Updated

7 years ago
Depends on: 735407
(Reporter)

Updated

7 years ago
Depends on: 735661
(Reporter)

Updated

7 years ago
Depends on: 735974
(Reporter)

Updated

7 years ago
Depends on: 739016
(Reporter)

Updated

7 years ago
Depends on: 743634
No longer depends on: 743634
(Reporter)

Updated

7 years ago
Depends on: 732471
(Reporter)

Updated

7 years ago
blocking-kilimanjaro: --- → ?
(Reporter)

Updated

7 years ago
Depends on: 748044
(Reporter)

Updated

7 years ago
Depends on: 749535
(Reporter)

Comment 4

7 years ago
This kind of giant-scope meta bug is not wanted for K9O.
(Reporter)

Updated

7 years ago
blocking-kilimanjaro: ? → -
(Reporter)

Updated

7 years ago
Depends on: 756449
(Reporter)

Updated

7 years ago
Depends on: 757378
(Reporter)

Updated

7 years ago
Depends on: 750947
(Reporter)

Updated

7 years ago
Depends on: 760611
(Reporter)

Updated

7 years ago
Depends on: 759894
(Reporter)

Updated

7 years ago
Depends on: 763713
(Reporter)

Updated

7 years ago
Depends on: 769765
(Reporter)

Updated

7 years ago
Depends on: 769911
(Reporter)

Updated

7 years ago
Depends on: 771738
(Reporter)

Updated

7 years ago
Depends on: 771737
(Reporter)

Updated

7 years ago
Depends on: 772329
(Reporter)

Updated

7 years ago
Depends on: 772334
(Reporter)

Updated

7 years ago
Depends on: 773936
(Reporter)

Updated

7 years ago
Depends on: 774119
(Reporter)

Updated

7 years ago
Depends on: 773859
(Reporter)

Updated

7 years ago
Depends on: 780006
Depends on: 782913

Updated

6 years ago
Duplicate of this bug: 386771

Comment 6

6 years ago
Is this still for JM or SM too or just IM, or JS in general? If so, please clarify the summary/headline.
(Reporter)

Updated

6 years ago
Depends on: 841956
Depends on: 914956
Depends on: 934725
Depends on: 947048
Assignee: general → nobody
Depends on: 1131099
Keywords: meta
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.