The default bug view has changed. See this FAQ.

Remove nsIDOMWindow2 and nsIDOMWindow_2_0_BRANCH

RESOLVED FIXED in mozilla7

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

({dev-doc-complete})

Trunk
mozilla7
dev-doc-complete
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 539629 [details] [diff] [review]
nsIDOMWindow2 v1
Attachment #539629 - Flags: review?(peterv)
Flags: in-testsuite-
(Assignee)

Comment 1

6 years ago
Created attachment 539630 [details] [diff] [review]
nsIDOMWindow_2_0_BRANCH v1
Attachment #539630 - Flags: review?(peterv)
Comment on attachment 539629 [details] [diff] [review]
nsIDOMWindow2 v1

Review of attachment 539629 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/interfaces/base/nsIDOMWindowInternal.idl
@@ +53,3 @@
>  
>  [scriptable, uuid(3a7b0839-b9d6-42ff-8ba6-910aba60a966)]
> +interface nsIDOMWindowInternal : nsIDOMWindow

Maybe change this IID too?
Attachment #539629 - Flags: review?(peterv) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 539629 [details] [diff] [review]
nsIDOMWindow2 v1

http://hg.mozilla.org/mozilla-central/rev/febcc9a25a8f
Attachment #539629 - Flags: checkin+
(Assignee)

Comment 4

6 years ago
Created attachment 542770 [details] [diff] [review]
Remove nsIDOMWindow_2_0_BRANCH interface
Attachment #542770 - Flags: review?(peterv)
(Assignee)

Updated

6 years ago
Attachment #539630 - Attachment is obsolete: true
Attachment #539630 - Flags: review?(peterv)
Comment on attachment 542770 [details] [diff] [review]
Remove nsIDOMWindow_2_0_BRANCH interface

Need to rev the IID on nsIDOMWindowInternal, no?
Attachment #542770 - Flags: review?(peterv) → review+
(Assignee)

Comment 6

6 years ago
Comment on attachment 542770 [details] [diff] [review]
Remove nsIDOMWindow_2_0_BRANCH interface

http://hg.mozilla.org/mozilla-central/rev/213c8c8b6a4c
Attachment #542770 - Flags: checkin+
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: dev-doc-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla7

Updated

6 years ago
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Updated

6 years ago
Duplicate of this bug: 645336
You need to log in before you can comment on or make changes to this bug.