Last Comment Bug 617539 - get rid of _MOZILLA_2_0_BRANCH interfaces on trunk after we branch
: get rid of _MOZILLA_2_0_BRANCH interfaces on trunk after we branch
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Benjamin Smedberg [:bsmedberg]
:
:
Mentors:
: 611101 638548 645844 (view as bug list)
Depends on: bump-to-2.1 post2.0 611101 651177 664543 664979 672166 672172
Blocks: 653418
  Show dependency treegraph
 
Reported: 2010-12-08 00:14 PST by Timothy Nikkel (:tnikkel)
Modified: 2012-01-05 08:51 PST (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
nsIWidget, rev. 1 (22.70 KB, patch)
2011-03-10 11:59 PST, Benjamin Smedberg [:bsmedberg]
jmathies: review+
Details | Diff | Splinter Review
nsIDOMWindowUtils, rev. 1 (13.84 KB, patch)
2011-03-10 11:59 PST, Benjamin Smedberg [:bsmedberg]
bzbarsky: review+
Details | Diff | Splinter Review
nsIPlugin*, rev. 1 (36.85 KB, patch)
2011-03-10 12:00 PST, Benjamin Smedberg [:bsmedberg]
jst: review+
Details | Diff | Splinter Review
nsIDOMNSDocument, rev. 1 (7.32 KB, patch)
2011-03-16 08:45 PDT, Benjamin Smedberg [:bsmedberg]
jonas: review+
Details | Diff | Splinter Review
nsIDOMNSHistory, rev. 1 (3.73 KB, patch)
2011-03-16 09:06 PDT, Benjamin Smedberg [:bsmedberg]
bugs: review+
Details | Diff | Splinter Review
nsIContentPrefService, rev. 1 (6.82 KB, patch)
2011-03-16 09:06 PDT, Benjamin Smedberg [:bsmedberg]
gavin.sharp: review+
Details | Diff | Splinter Review
nsIFocusManager, rev. 1 (3.65 KB, patch)
2011-03-16 09:07 PDT, Benjamin Smedberg [:bsmedberg]
bugs: review+
Details | Diff | Splinter Review
nsIDocShell, rev. 1 (4.64 KB, patch)
2011-03-16 13:34 PDT, Benjamin Smedberg [:bsmedberg]
bzbarsky: review+
Details | Diff | Splinter Review
nsIContentViewer, rev. 1 (3.78 KB, patch)
2011-03-16 13:38 PDT, Benjamin Smedberg [:bsmedberg]
jonas: review+
Details | Diff | Splinter Review
nsIDOMHTMLSelectElement, rev. 1 (6.48 KB, patch)
2011-03-16 13:40 PDT, Benjamin Smedberg [:bsmedberg]
bugs: review+
Details | Diff | Splinter Review
nsIDOMWebGLRenderingContext, rev. 1 (4.48 KB, patch)
2011-03-16 13:42 PDT, Benjamin Smedberg [:bsmedberg]
jmuizelaar: review+
Details | Diff | Splinter Review
nsIFrameLoader, rev. 1 (6.79 KB, patch)
2011-03-16 13:43 PDT, Benjamin Smedberg [:bsmedberg]
bzbarsky: review+
Details | Diff | Splinter Review
nsIMenuBoxObject, rev. 1 (3.22 KB, patch)
2011-03-16 13:44 PDT, Benjamin Smedberg [:bsmedberg]
enndeakin: review+
Details | Diff | Splinter Review
nsIAppStartup, rev. 1 (6.06 KB, patch)
2011-03-16 13:45 PDT, Benjamin Smedberg [:bsmedberg]
dtownsend: review+
Details | Diff | Splinter Review
nsIRadioGroupContainer, rev. 1 (9.65 KB, patch)
2011-03-16 13:46 PDT, Benjamin Smedberg [:bsmedberg]
bzbarsky: review+
Details | Diff | Splinter Review
mobile-browser changes, rev. 1 (4.83 KB, patch)
2011-03-24 11:44 PDT, Benjamin Smedberg [:bsmedberg]
mark.finkle: review+
Details | Diff | Splinter Review
nsIPresShell (18.16 KB, patch)
2011-03-27 21:08 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
tnikkel: review+
Details | Diff | Splinter Review
nsIEditor (4.99 KB, patch)
2011-04-11 09:03 PDT, :Ehsan Akhgari
roc: review+
Details | Diff | Splinter Review
nsIMarkupDocumentViewer, rev. 1 (7.44 KB, patch)
2011-05-29 14:38 PDT, Ed Morley [:emorley]
smontagu: review+
mounir: checkin+
Details | Diff | Splinter Review
nsIScreen, rev. 1 (7.45 KB, patch)
2011-05-29 15:29 PDT, Ed Morley [:emorley]
no flags Details | Diff | Splinter Review
nsIRadioGroupContainer, rev. 1.1 (9.37 KB, patch)
2011-07-18 06:01 PDT, Ed Morley [:emorley]
emorley: review+
mounir: feedback+
Ms2ger: checkin+
Details | Diff | Splinter Review

Description Timothy Nikkel (:tnikkel) 2010-12-08 00:14:52 PST
We've had to add a number of _MOZILLA_2_0_BRANCH interfaces to avoid IID changes. We should get rid of them on trunk once we branch for real.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-03-04 09:01:49 PST
*** Bug 611101 has been marked as a duplicate of this bug. ***
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-03-04 09:02:04 PST
*** Bug 638548 has been marked as a duplicate of this bug. ***
Comment 3 Benjamin Smedberg [:bsmedberg] 2011-03-10 11:59:06 PST
Created attachment 518479 [details] [diff] [review]
nsIWidget, rev. 1
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-03-10 11:59:27 PST
Created attachment 518480 [details] [diff] [review]
nsIDOMWindowUtils, rev. 1
Comment 5 Benjamin Smedberg [:bsmedberg] 2011-03-10 12:00:21 PST
Created attachment 518481 [details] [diff] [review]
nsIPlugin*, rev. 1

Because of ill-conceived %{C++ blocks in nsIPluginHost, the vtables were ending up incorrect, so I had to do a slight bit more surgery for this one.
Comment 6 Benjamin Smedberg [:bsmedberg] 2011-03-10 12:00:34 PST
These all passed tryserver.
Comment 7 Jim Mathies [:jimm] 2011-03-10 12:09:05 PST
Comment on attachment 518479 [details] [diff] [review]
nsIWidget, rev. 1

In nsIWidget.h you can remove the old transparency method UpdatePossiblyTransparentRegion as well. UpdateTransparentRegion replaces it.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2011-03-10 12:27:03 PST
Comment on attachment 518480 [details] [diff] [review]
nsIDOMWindowUtils, rev. 1

You need to rev the nsIDOMWindowUtils iid.

r=me with that.
Comment 9 Benjamin Smedberg [:bsmedberg] 2011-03-16 08:45:29 PDT
Created attachment 519668 [details] [diff] [review]
nsIDOMNSDocument, rev. 1
Comment 10 Benjamin Smedberg [:bsmedberg] 2011-03-16 09:06:14 PDT
Created attachment 519676 [details] [diff] [review]
nsIDOMNSHistory, rev. 1
Comment 11 Benjamin Smedberg [:bsmedberg] 2011-03-16 09:06:43 PDT
Created attachment 519677 [details] [diff] [review]
nsIContentPrefService, rev. 1
Comment 12 Benjamin Smedberg [:bsmedberg] 2011-03-16 09:07:55 PDT
Created attachment 519678 [details] [diff] [review]
nsIFocusManager, rev. 1
Comment 13 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-16 10:47:51 PDT
Comment on attachment 519668 [details] [diff] [review]
nsIDOMNSDocument, rev. 1

Thanks!
Comment 14 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-16 10:48:33 PDT
Comment on attachment 519668 [details] [diff] [review]
nsIDOMNSDocument, rev. 1

Oh, but you do need to rev the nsIDocument iid
Comment 15 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-03-16 13:32:14 PDT
Comment on attachment 519677 [details] [diff] [review]
nsIContentPrefService, rev. 1

Oh, this actually revs the IID on the wrong interface (nsIContentPrefObserver instead of nsIContentPrefService) - need to fix that!
Comment 16 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:34:03 PDT
Created attachment 519759 [details] [diff] [review]
nsIDocShell, rev. 1
Comment 17 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:38:21 PDT
Created attachment 519760 [details] [diff] [review]
nsIContentViewer, rev. 1
Comment 18 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:40:22 PDT
Created attachment 519762 [details] [diff] [review]
nsIDOMHTMLSelectElement, rev. 1
Comment 19 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:42:37 PDT
Created attachment 519764 [details] [diff] [review]
nsIDOMWebGLRenderingContext, rev. 1
Comment 20 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:43:34 PDT
Created attachment 519765 [details] [diff] [review]
nsIFrameLoader, rev. 1
Comment 21 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:44:19 PDT
Created attachment 519766 [details] [diff] [review]
nsIMenuBoxObject, rev. 1
Comment 22 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:45:26 PDT
Created attachment 519767 [details] [diff] [review]
nsIAppStartup, rev. 1
Comment 23 Benjamin Smedberg [:bsmedberg] 2011-03-16 13:46:31 PDT
Created attachment 519768 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1
Comment 24 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-16 14:56:39 PDT
Comment on attachment 519760 [details] [diff] [review]
nsIContentViewer, rev. 1

r=me if you rev the iid.
Comment 25 Boris Zbarsky [:bz] (still a bit busy) 2011-03-17 06:48:31 PDT
Comment on attachment 519759 [details] [diff] [review]
nsIDocShell, rev. 1

r=me
Comment 26 Boris Zbarsky [:bz] (still a bit busy) 2011-03-17 06:52:15 PDT
Comment on attachment 519765 [details] [diff] [review]
nsIFrameLoader, rev. 1

Nix the interface from the idl file too?   And rev the nsIFrameLoader iid.

r=me with those two changes.
Comment 27 Boris Zbarsky [:bz] (still a bit busy) 2011-03-17 06:53:05 PDT
Comment on attachment 519768 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1

r=me, but please coordinate with Mounir: he has a bunch of changes to this code too.
Comment 28 Benjamin Smedberg [:bsmedberg] 2011-03-24 11:44:40 PDT
Created attachment 521573 [details] [diff] [review]
mobile-browser changes, rev. 1
Comment 30 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-27 21:08:38 PDT
Created attachment 522286 [details] [diff] [review]
nsIPresShell
Comment 31 Justin Lebar (not reading bugmail) 2011-03-28 14:47:19 PDT
*** Bug 645844 has been marked as a duplicate of this bug. ***
Comment 32 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-31 18:58:20 PDT
http://hg.mozilla.org/mozilla-central/rev/0dc8fb9d0bc3 - nsIPresShell
Comment 33 Johnny Stenback (:jst, jst@mozilla.com) 2011-04-06 22:09:52 PDT
Comment on attachment 518481 [details] [diff] [review]
nsIPlugin*, rev. 1

Duh, I reviewed this when the request was made, but clearly forgot to mark it :( r=jst
Comment 34 :Ehsan Akhgari 2011-04-11 09:03:13 PDT
Created attachment 525083 [details] [diff] [review]
nsIEditor
Comment 35 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-11 09:30:23 PDT
Comment on attachment 525083 [details] [diff] [review]
nsIEditor

Please land this before we branch :-)
Comment 36 :Ms2ger (⌚ UTC+1/+2) 2011-04-11 09:37:03 PDT
And land attachment 518481 [details] [diff] [review] along with it? :)
Comment 38 :Ehsan Akhgari 2011-04-11 13:18:12 PDT
http://hg.mozilla.org/mozilla-central/rev/0d60751c978e (nsIContentUtils_MOZILLA_2_0_BRANCH)

This patch is a straight backout of http://hg.mozilla.org/mozilla-central/rev/5e1f1bb2bb87 which added that class for the mere sake of non-libxul builds (which are now history).
Comment 39 :Ehsan Akhgari 2011-04-11 16:58:57 PDT
Josh, should I back http://hg.mozilla.org/mozilla-central/rev/3aebb305dee5 out?  Benjamin said that he left this unlanded on purpose because you had a pending patch to remove these entirely...
Comment 40 Josh Aas 2011-04-12 00:24:20 PDT
Don't back it out, the removal patch of mine won't be in FF5 and I have to update it anyway. I'd prefer to have the MOZILLA_2_0_BRANCH stuff gone now. Thanks for landing it.
Comment 41 Steven Michaud [:smichaud] (Retired) 2011-04-19 10:24:45 PDT
The patch for this bug contains a mistake that triggered bug 651177.
Comment 42 Ed Morley [:emorley] 2011-05-29 13:33:41 PDT
According to MXR, there is now just the following remaining...
- nsIRadioGroupContainer (dealt with by Attachment #519768 [details] [diff], pending comment 27)
- nsIMarkupDocumentViewer
- nsIScreen
- A leftover from nsIDOMWindowUtils, presume it can be taken out too?
http://mxr.mozilla.org/mozilla-central/source/layout/ipc/test-ipcbrowser-content.js#8

Presume it's ok for me to work on nsIMarkupDocumentViewer and nsIScreen / no one else is currently doing them?
Comment 43 Ed Morley [:emorley] 2011-05-29 14:38:02 PDT
Created attachment 535962 [details] [diff] [review]
nsIMarkupDocumentViewer, rev. 1
Comment 44 Ed Morley [:emorley] 2011-05-29 15:29:17 PDT
Created attachment 535965 [details] [diff] [review]
nsIScreen, rev. 1
Comment 45 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-29 15:59:00 PDT
Comment on attachment 535965 [details] [diff] [review]
nsIScreen, rev. 1

Review of attachment 535965 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 46 :Ms2ger (⌚ UTC+1/+2) 2011-05-30 09:40:33 PDT
Comment on attachment 535962 [details] [diff] [review]
nsIMarkupDocumentViewer, rev. 1

http://hg.mozilla.org/projects/cedar/rev/102449094763
Comment 47 :Ehsan Akhgari 2011-05-30 11:26:51 PDT
(In reply to comment #46)
> Comment on attachment 535962 [details] [diff] [review] [review]
> nsIMarkupDocumentViewer, rev. 1
> 
> http://hg.mozilla.org/projects/cedar/rev/102449094763

http://hg.mozilla.org/mozilla-central/rev/102449094763
Comment 48 Ed Morley [:emorley] 2011-07-18 03:05:29 PDT
Comment on attachment 535965 [details] [diff] [review]
nsIScreen, rev. 1

Fails try; breaking out to bug 672166 to resolve.
Comment 49 Ed Morley [:emorley] 2011-07-18 06:01:02 PDT
Created attachment 546514 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1.1

Other than the dependant bugs, nsIRadioGroupContainer is the last interface needing to be dealt with here (according to MXR at least), so have updated the existing patch so this can be closed.

Is bsmedbergs patch updated to tip, carrying forwards bz's r+

Mounir, can you confirm this is ok to land please? (see comment 27)
Comment 50 Mounir Lamouri (:mounir) 2011-07-18 12:22:57 PDT
Comment on attachment 546514 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1.1

Review of attachment 546514 [details] [diff] [review]:
-----------------------------------------------------------------

I indeed have some patches touching nsIRadioGroupContainer but given that they still haven't landed, I will take the burden of the merge instead of delay this more.

Thanks for refreshing the patch Ed :)
Comment 51 Ed Morley [:emorley] 2011-07-18 12:55:31 PDT
Comment on attachment 546514 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1.1

Great, thanks Mounir :-)

Passed try:
http://dev.philringnalda.com/tbpl/?tree=Try&rev=6ef91a400cf4
Comment 52 :Ms2ger (⌚ UTC+1/+2) 2011-07-19 03:09:12 PDT
Comment on attachment 546514 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1.1

http://hg.mozilla.org/integration/mozilla-inbound/rev/1ed3d5d62d91
Comment 53 :Ehsan Akhgari 2011-07-19 11:32:28 PDT
Comment on attachment 546514 [details] [diff] [review]
nsIRadioGroupContainer, rev. 1.1

http://hg.mozilla.org/mozilla-central/rev/1ed3d5d62d91
Comment 54 Ed Morley [:emorley] 2012-01-05 08:51:19 PST
Now that bug 672166 has landed, believe we're all done here (comment remnant being dealt with in that bug):
http://mxr.mozilla.org/mozilla-central/search?string=MOZILLA_2&case=1

Note You need to log in before you can comment on or make changes to this bug.