Phantom Email 12-31-1969 - 18:00 when erasing a message from the Trash and trying to recovering by pressing ctrl+z or cmd+z

RESOLVED DUPLICATE of bug 209189

Status

defect
RESOLVED DUPLICATE of bug 209189
8 years ago
6 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (MultiLang) (like Firefox/3.0.19)
Build Identifier: 20110528090207

A phantom and empty email, dated 31 december 1968 at 18.00 appeared when I was checking the emails in the trash folder, I removed for error one email that was important, then I tried to recover it by pressing cmd+z (I am an OSX user) and I got in the inbox a message without subject, text... nothing! With the date as specified.

I tried to recreate the problem and it happen every time, if you do it more than twice then the trash will warn you about an operation that it will never finish until you will restart the application

Reproducible: Always

Steps to Reproduce:
1. Go in the Trash folder, erase a message
2. Press CMD+Z (or CTRL if you are a Windows User)
3. Inbox will show the bold (1)

Actual Results:  
I tried to search for this new message that was not appearing at the bottom, and I found the empty message with the strange date.

Expected Results:  
As usual, getting back a erased message!

OS X, v. 10.5.8 - Thunderbird Beta 5.01b

My thunderbird is configured to work multi-accounts.

about:buildconfig
Source

Built from http://hg.mozilla.org/releases/mozilla-miramar/rev/c93fe6829c74
Build platform
target
i386-apple-darwin10.5.0
Build tools
Compiler 	Version 	Compiler flags
gcc-4.2 -arch i386 	gcc version 4.2.1 (Apple Inc. build 5664) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch i386 	gcc version 4.2.1 (Apple Inc. build 5664) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments

--target=i386-apple-darwin10.5.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.5.sdk --enable-application=mail --enable-update-channel=beta --enable-update-packaging --enable-optimize --disable-debug --enable-tests --enable-official-branding --enable-debug-symbols=-gdwarf-2 --target=i386-apple-darwin10.5.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.5.sdk --enable-application=mail --enable-update-channel=beta --enable-update-packaging --enable-optimize --disable-debug --enable-tests --enable-official-branding --enable-debug-symbols=-gdwarf-2 --enable-application=../mail --disable-official-branding --with-branding=../other-licenses/branding/thunderbird --cache-file=.././config.cache --srcdir=/builds/slave/macosx64_build_50/build/mozilla
Source

Built from http://hg.mozilla.org/releases/mozilla-miramar/rev/c93fe6829c74
Build platform
target
x86_64-apple-darwin10.5.0
Build tools
Compiler 	Version 	Compiler flags
gcc-4.2 -arch x86_64 	gcc version 4.2.1 (Apple Inc. build 5664) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch x86_64 	gcc version 4.2.1 (Apple Inc. build 5664) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments

--target=x86_64-apple-darwin10.5.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk --enable-application=mail --enable-update-channel=beta --enable-update-packaging --enable-optimize --disable-debug --enable-tests --enable-official-branding --enable-debug-symbols=-gdwarf-2 --target=x86_64-apple-darwin10.5.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk --enable-application=mail --enable-update-channel=beta --enable-update-packaging --enable-optimize --disable-debug --enable-tests --enable-official-branding --enable-debug-symbols=-gdwarf-2 --enable-application=../mail --disable-official-branding --with-branding=../other-licenses/branding/thunderbird --cache-file=.././config.cache --srcdir=/builds/slave/macosx64_build_50/build/mozilla
Did you try to rebuild the trash folder index ?

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209189
You need to log in before you can comment on or make changes to this bug.