Last Comment Bug 664670 - imageDataCb passed to Storage.getTabData in TabItem__reconnect runs when the tab is already gone
: imageDataCb passed to Storage.getTabData in TabItem__reconnect runs when the ...
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 8
Assigned To: Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
:
Mentors:
: 670852 (view as bug list)
Depends on:
Blocks: 604699 660175
  Show dependency treegraph
 
Reported: 2011-06-16 00:41 PDT by Dão Gottwald [:dao]
Modified: 2016-04-12 14:00 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v1 (1.08 KB, patch)
2011-07-07 14:27 PDT, Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
dao+bmo: review+
raymond: feedback+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-06-16 00:41:11 PDT
Seen in browser-chrome test logs:

JavaScript Error: "self.tab is null" {file: "chrome://browser/content/tabview.js" line: 5178}
Comment 1 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-07-07 14:27:13 PDT
Created attachment 544619 [details] [diff] [review]
patch v1

I'd like to have checked in ThumbnailStorage.loadThumbnail() whether the given tab is still linked to a TabItem before executing the callback but that's not possible as the tab might have been re-used be SS/SR in the meantime. So we need to check if the TabItem is still linked to a tab in TabItem._reconnect();
Comment 2 Dão Gottwald [:dao] 2011-07-08 01:13:28 PDT
Comment on attachment 544619 [details] [diff] [review]
patch v1

I don't think there's a point in checking tabData before self.tab.
Comment 3 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-07-08 05:54:41 PDT
http://hg.mozilla.org/integration/fx-team/rev/3c57112a6a6f
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-07-08 07:52:06 PDT
http://hg.mozilla.org/mozilla-central/rev/3c57112a6a6f
Comment 5 Dão Gottwald [:dao] 2011-07-12 00:08:45 PDT
*** Bug 670852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.