Javascript loaded fail to function in form submission

VERIFIED DUPLICATE of bug 66508

Status

()

Core
Networking
--
critical
VERIFIED DUPLICATE of bug 66508
17 years ago
17 years ago

People

(Reporter: hirata masakazu, Assigned: gordon)

Tracking

Trunk
mozilla0.8
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
2001012413MTrunk.
Goto URL
type any keyword in the box and hit GO.
This button seems to be JavaScript coded and hitting Return key instead of
clicking Go submits the query.

Comment 1

17 years ago
Works for me with build 2001012420 on NT4, as long as I have Javascript
enabled.  When I disable it, I get the behaviour you describe.  I think this
is an error in the web page, which doesn't support a non-Javascript browser
correctly.  Please reopen if this is still not working for you with Javascript
enabled.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
One: you can not simply resolve it as WFM unless you test in the same platform
(MacOS 9.x in this case). This could be a Mac-only bug.
Two: this happens with Javascript enabled in the advanced preferences.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

17 years ago
Okay, sorry about that.
Nominating for 0.8
Target Milestone: --- → mozilla0.8
there was a bug fixed a week or so ago where we couldn't submit forms with an
image submit button (only on mac). Try this in a current build and see if it
still happens.

Comment 6

17 years ago
waqar could you check this out? - reassigning 
Assignee: rods → waqar
Status: REOPENED → NEW
(Reporter)

Comment 7

17 years ago
I assume this bug has nothing to do with input type="image" bug 63846 mentioned
above, since it started after the fix, and it does not use an image for the button.
I am wondering if this one shares an error with bug 66654 where some Javascript
is not working.
(Reporter)

Comment 8

17 years ago
I did some digging into this URL. The URL calls a Javascript defined in another
page:http://www.ncbi.nlm.nih.gov/entrez/query/query.js
When I copied and pasted the JS definition into the header of the page instead,
the button worked. I am not sure what is causing this, since hitting return key
is also defined by the same page. I will try to make a simplified test case out
of it later.
(Reporter)

Comment 9

17 years ago
Here are the two testcases. Test1.html is the working ex. Go button and the four
links (limits, etc) works. In Test2.html, the JS functions are defined
elsewhere. Here, Clear button and hitting return key works, but Go button and
the four links do not work.
 Updating the summary, and trying Networking.
Component: Form Submission → Networking
Summary: Form submission button (Javascript?) is broken for the URL → Javascript loaded fail to function in form submission
(Reporter)

Comment 10

17 years ago
Created attachment 24308 [details]
test1.html that has JS defined within the page.
(Reporter)

Comment 11

17 years ago
Created attachment 24310 [details]
test2.html that loads JS definition from outside, which shows this bug.
(Reporter)

Comment 12

17 years ago
*** Bug 66654 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

17 years ago
Although there are some bugs regarding <script src=URL> in Bugzilla, this
particular bug clearly started in 0124 build, and the URL above and cnn.com
works in 0122 build. Therefore, I do not think this is a direct dupe of bug
18843, bug 63427, or bug 48974.
(Reporter)

Comment 14

17 years ago
nomination corrected
Keywords: mozilla0.8
(Reporter)

Comment 15

17 years ago
Querying Bonsai for the window of opportunity for this bug (between 012206 build
and 012413 build) within mozilla/js directory shows only changes in
mozilla/js/rhino/ by nboyd@atg.com .

Comment 16

17 years ago
Reassigning to Networking owner then and adding nboyd@atg.com to Cc for
comments.
Assignee: waqar → neeti
QA Contact: vladimire → tever

Comment 17

17 years ago
This is a regression caused by the fix for bug 56170, and is the same problem as 
the image loading issue in bug 66508.
Assignee: neeti → gordon

Comment 18

17 years ago
simon sez this is a dup. marking as such. 

*** This bug has been marked as a duplicate of 66508 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Keywords: mozilla0.8

Comment 19

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.