Update on the beta channel caused a switch to the release channel

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: spammaaja, Unassigned)

Tracking

({regression})

5 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

Update on the beta channel caused a switch to the release channel.

http://hg.mozilla.org/releases/mozilla-release/rev/7b56ff900c2a

--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-tests --enable-official-branding

Reproducible: Always


Actual Results:  
Beta channel became release with an update.

Expected Results:  
If you are on the beta channel, it should stay in the beta channel like Chrome.
(Reporter)

Updated

7 years ago
Whiteboard: [parity-chrome]
Version: unspecified → 5 Branch
(Reporter)

Comment 1

7 years ago
Caused by Bug 659972 - Remove channel switching UI ?
Blocks: 659972
Keywords: regression
Hmm, my channel-prefs.js with above Build still says "pref("app.update.channel", "beta");". Isn't that saying it's staying on Beta Channel?

Comment 3

7 years ago
Mine is too.  I suspect what has happened is not that update channel has switched, but that the release candidate build (from the releases development "channel") has been intentionally given to beta users.  That makes sense in terms of the sequence of releases, although it means there's a temporary mismatch between the development "channels" and the app update channels.
Yeah, the RC was pushed to the beta channel. This isn't a problem, because updates can never change the channel that you're on (channel-prefs.js is explicitly left untouched by the updater).
No longer blocks: 659972
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: [parity-chrome]
You need to log in before you can comment on or make changes to this bug.