Last Comment Bug 665502 - tabItems are resized when closing the active tab in a group
: tabItems are resized when closing the active tab in a group
Status: VERIFIED FIXED
: regression
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- normal
: Firefox 7
Assigned To: Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
:
Mentors:
Depends on: 610208 642793
Blocks: 660175
  Show dependency treegraph
 
Reported: 2011-06-20 03:32 PDT by Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
ehsan: in‑testsuite+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v1 (3.21 KB, patch)
2011-06-20 04:50 PDT, Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
no flags Details | Diff | Splinter Review
patch v2 (3.17 KB, patch)
2011-06-20 05:16 PDT, Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
dietrich: review+
raymond: feedback+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 03:32:20 PDT

    
Comment 1 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 04:33:36 PDT
Regressed since bug 642793.
Comment 2 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 04:50:52 PDT
Created attachment 540434 [details] [diff] [review]
patch v1
Comment 3 Dão Gottwald [:dao] 2011-06-20 05:02:19 PDT
Comment on attachment 540434 [details] [diff] [review]
patch v1

>+      win.gBrowser.loadOneTab("about:blank", {inBackground: true});

Why isn't this just win.gBrowser.addTab();?
Comment 4 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 05:04:43 PDT
(In reply to comment #3)
> >+      win.gBrowser.loadOneTab("about:blank", {inBackground: true});
> 
> Why isn't this just win.gBrowser.addTab();?

Because that would add a new tab and make it the selectedTab, right? I wanted the first tab to stay selected.
Comment 5 Dão Gottwald [:dao] 2011-06-20 05:05:42 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > >+      win.gBrowser.loadOneTab("about:blank", {inBackground: true});
> > 
> > Why isn't this just win.gBrowser.addTab();?
> 
> Because that would add a new tab and make it the selectedTab, right?

Nope, addTab never does that.
Comment 6 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 05:16:50 PDT
Created attachment 540438 [details] [diff] [review]
patch v2

Replaced gBrowser.loadOneTab() with gBrowser.addTab()
Comment 7 Raymond Lee [:raymondlee] 2011-06-20 05:20:44 PDT
Comment on attachment 540438 [details] [diff] [review]
patch v2

Looks good!
Comment 8 Dietrich Ayala (:dietrich) 2011-06-20 08:23:25 PDT
Comment on attachment 540438 [details] [diff] [review]
patch v2

Review of attachment 540438 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 9 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-06-20 09:37:14 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f7a2b52a76fd
Comment 11 George Carstoiu 2011-06-27 07:23:38 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110626 Firefox/7.0a1

Verified on Ubuntu 11.04 x86, Mac OS X 10.6, Win 7 x86, Win XP using the following steps:
1. Open several tabs
2. Enter Panorama
3. Close the focused tab and observe the other tabs.

Issue is no longer reproducible. Setting status to Verified Fixed.

Note You need to log in before you can comment on or make changes to this bug.