[Regression] Restart notification is still displayed when the current language pack is selected again

RESOLVED DUPLICATE of bug 688824

Status

Firefox for Android Graveyard
General
P3
normal
RESOLVED DUPLICATE of bug 688824
7 years ago
5 years ago

People

(Reporter: xti, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression

Details

(Reporter)

Description

7 years ago
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110619
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Open Fennec App
2. Go to Preferences -> Language and choose another language then the current one
3. Choose the language which was set before step 2.

Expected result:
After steps 2, the Restart notification is displayed on the top of the screen. After step 3 the popup is dismissed.

Actual result:
Restart notification is still displayed after step 3.
(Reporter)

Updated

7 years ago
Depends on: 648543
Whiteboard: [regression]

Updated

7 years ago
Keywords: regression
Whiteboard: [regression]

Comment 1

7 years ago
able to reproduce on Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 Fennec/7.0a1. 

One note, restart notification only appears when going to another locale.  if cancelling that selection, and going back to the original locale selected, the restart notification bar does not appear.
Priority: -- → P3
I believe some changes take affect to the active profile regardless of browser restart on language selection so this might not actually be a bug. Mark/Matt?
(Reporter)

Comment 3

7 years ago
This issue is still reproducing on the latest Nightly and Aurora builds.

--
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110930
Firefox/10.0a1 Fennec/10.0a1
Device: Samsung Galaxy S
OS: Android 2.2

Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110930
Firefox/9.0a2 Fennec/9.0a2
Device: Samsung Galaxy S
OS: Android 2.2
tracking-fennec: --- → ?
Version: Firefox 7 → Trunk
Forward-duping this to bug 688824 because that bug has a patch.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 688824
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.