Intermittent TEST-UNEXPECTED-PASS | browser_tapping.js | Fired a good double tap

RESOLVED DUPLICATE of bug 698387

Status

defect
RESOLVED DUPLICATE of bug 698387
8 years ago
7 years ago

People

(Reporter: philor, Assigned: mbrubeck)

Tracking

({intermittent-failure})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile_unittests])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
The unfortunate side-effect of fixing the permaorange of bug 651554 on Android is that we don't really *always* fail to fire a good double tap, just 499 times out of a 500 or so, and so the remaining 1 is now

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308592919.1308594814.10986.gz
Android Tegra 250 mozilla-inbound opt test browser-chrome on 2011/06/20 11:01:59
s: tegra-071

TEST-UNEXPECTED-PASS | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Fired a good double tap
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(Reporter)

Comment 33

8 years ago
Makes for a neat little problem: this has clearly gotten worse recently, which means it's gotten better (we're actually passing the test more than once a fortnight), but the only place to go from here is to mark it as random and never realize when it's completely fixed.

Well, or someone could actually look at the test, see why it mostly fails, and fix it, I guess :)
(Assignee)

Comment 34

8 years ago
This test is also random on desktop (although it's not marked as TODO there), so it shouldn't be too hard to investigate.
Assignee: nobody → mbrubeck
OS: Windows XP → Android
Hardware: x86 → All
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 42

8 years ago
This test behaves differently depending on the screen size, probably because the taps end up in a different part of the loaded document.
(Assignee)

Comment 43

8 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #42)
> This test behaves differently depending on the screen size, probably because
> the taps end up in a different part of the loaded document.

Or maybe not... I thought it was failing only at certain screen sizes, but after more testing it seems it was just a coincidence.
(Assignee)

Comment 44

8 years ago
The failures I'm seeing on desktop are because of timer issues.  In input.js we fire a single click after a 400ms delay so we can detect double-clicks.  The test waits 500ms and then checks whether the single click was fired.  But sometimes the single-click timer takes longer than 500 seconds, probably because other code is running on the main thread at the time.
(Assignee)

Comment 45

8 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #44)
> But sometimes the single-click timer takes longer than 500 seconds[...]

I mean milliseconds, of course.
(Assignee)

Comment 46

8 years ago
Posted patch logging patchSplinter Review
I pushed this patch to Try:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=fd25881a7e8e

The failures I'm seeing on Android are totally different than the ones I see on desktop.  On Try, we are getting an extra mouse click from... somewhere... during the single-click test, and it is throwing off the double-click test:

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Test the double tap behavior
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Test good single tap: 1317819765428

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _commitAnotherClick: 1317819765443
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _singleClickTimeout.once: 1317819765443
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _doSingleClick: 1317819765842

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _commitAnotherClick: 1317819765858
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _singleClickTimeout.once: 1317819765858

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Check good single tap: 1317819765939

TEST-PASS | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Fired a good single tap
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Test good double tap: 1317819765940

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _commitAnotherClick: 1317819765949
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _singleClickTimeout.clear: 1317819765949
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _doDoubleClick: 1317819765950

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _commitAnotherClick: 1317819765960
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _singleClickTimeout.once: 1317819765960
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _doSingleClick: 1317819766364
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _commitAnotherClick: 1317819766384
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Console message: _singleClickTimeout.once: 1317819766384

TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Check good double tap: 1317819766463
TEST-INFO | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | ---- event check: failed match (TapDouble != TapSingle
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/mobile/chrome/tests/browser_tapping.js | Fired a good double tap
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
this is 4 months old, can we either fix this test in the next week or disable this test?
Whiteboard: [orange] → [orange][mobile_unittests]
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Depends on: 698387
Comment hidden (Legacy TBPL/Treeherder Robot)
disabled this test in bug 698387
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 698387
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange][mobile_unittests] → [mobile_unittests]
You need to log in before you can comment on or make changes to this bug.