thumbnails of long pages (e.g. planet.mozilla.org) are not updated correctly if page load was interrupted

VERIFIED FIXED

Status

Firefox Graveyard
Panorama
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: aceman, Unassigned)

Tracking

Details

(Whiteboard: [see comment 8 for valid steps to reproduce])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 540757 [details]
screenshot of blurry thumbnail

1. open planet.mozilla.org in a tab
2. enter panorama
3. see the thumbnail of the page is blurry (as in attachment)
4. exit panorama by clicking on the thumbnail
5. in this step the thumbnail gets sharpened correctly (as witnessed by entering panorama again)
6. scroll down the page
7. create a new tab
8. enter panorama
9. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position. On other pages this works.
I can't reproduce this. Everything works here as expected. Did you try with the latest nightly?
(Reporter)

Comment 2

6 years ago
This is on 5.0, Win XP. But can try nightly, will report.

You can also try modified steps:
2. switch to other tab
3. enter panorama
4. planet.mozilla.org thumbnail is completely empty (white).
Now continue at original step 4.
Status: NEW → UNCONFIRMED
Ever confirmed: false
WFM too on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110630 Firefox/7.0a1
(Reporter)

Comment 4

6 years ago
OK, I have tried it on another machine with Windows XP, Nvidia card and HW acceleration enabled. I can't reproduce the problem there.
The machine that reproduces it has an Intel card and HW disabled (old driver).
(Reporter)

Comment 5

6 years ago
I am now back at the original machine (with Intel), where this was spotted. Another facts:
the problem appears when the page is not fully loaded:
1. enter the url, press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. now the problem happens, continue at step 2 in comment 2.

When at step 4 loading is not interrupted and I wait until the page is fully loaded with all images, the thumbnail works fine.
Summary: thumbnails of long pages (e.g. planet.mozilla.org) are not updated correctly → thumbnails of long pages (e.g. planet.mozilla.org) are not updated correctly if page load was interrupted
(Reporter)

Comment 6

6 years ago
With these steps I can reproduce it on another machine using Aurora 7, Linux.
(Reporter)

Updated

6 years ago
OS: Windows XP → All
Version: 5 Branch → Trunk
(Reporter)

Comment 7

6 years ago
Revised steps to reproduce (obsoleting comments 0,2,5):
1. enter the URL of long loading page (like planet.mozilla.org), press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. switch to another tab
5. enter panorama
6. planet.mozilla.org thumbnail is completely empty (white).
7. exit panorama by clicking on the thumbnail
5. in this step the thumbnail gets rendered correctly and zoomed in
6. scroll down the page
7. create a new tab
8. enter panorama
9. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position.
(Reporter)

Comment 8

6 years ago
One more try at correct steps.

Revised steps to reproduce (obsoleting comments 0,2,5,7):
1. enter the URL of long loading page (like planet.mozilla.org), press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. switch to another tab
5. enter panorama
6. planet.mozilla.org thumbnail is completely empty (white).
7. exit panorama by clicking on the thumbnail
8. in this step the thumbnail gets rendered correctly and zoomed in
9. scroll down the page
10. create a new tab
11. enter panorama
12. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position.

Comment 9

6 years ago
(In reply to aceman from comment #8)

Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110809 Firefox/8.0a1

> 3. press ESC or STOP while images are still loading.
> 4. switch to another tab
> 5. enter panorama
> 6. planet.mozilla.org thumbnail is completely empty (white).

Confirmed.

> 9. scroll down the page
> 10. create a new tab
> 11. enter panorama
> 12. see the thumbnail of planet.mozilla.org does not update to show the
> scrolled to position.

Confirmed.
(Reporter)

Comment 10

6 years ago
Thank you for confirmation.

I will mark this bug NEW, however there exists bug 659594 (which may have the same cause) and bug 598435 which may have some relevance.
If anybody really see the real cause of this, duplicate or set dependence as needed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [see comment 8 for valid steps to reproduce]
(Reporter)

Comment 11

6 years ago
Setting dependence on bug 659594 according to comments there.
Depends on: 659594
Fixed by bug 659594.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

5 years ago
Thanks! Confirming fixed in recent nightlies.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

a year ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.