Last Comment Bug 665906 - thumbnails of long pages (e.g. planet.mozilla.org) are not updated correctly if page load was interrupted
: thumbnails of long pages (e.g. planet.mozilla.org) are not updated correctly ...
Status: VERIFIED FIXED
[see comment 8 for valid steps to rep...
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 All
: -- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 659594
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-21 08:22 PDT by :aceman
Modified: 2016-04-12 14:00 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of blurry thumbnail (238.12 KB, image/png)
2011-06-21 08:22 PDT, :aceman
no flags Details

Description :aceman 2011-06-21 08:22:51 PDT
Created attachment 540757 [details]
screenshot of blurry thumbnail

1. open planet.mozilla.org in a tab
2. enter panorama
3. see the thumbnail of the page is blurry (as in attachment)
4. exit panorama by clicking on the thumbnail
5. in this step the thumbnail gets sharpened correctly (as witnessed by entering panorama again)
6. scroll down the page
7. create a new tab
8. enter panorama
9. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position. On other pages this works.
Comment 1 Tim Taubert [:ttaubert] 2011-06-30 00:59:12 PDT
I can't reproduce this. Everything works here as expected. Did you try with the latest nightly?
Comment 2 :aceman 2011-06-30 01:09:32 PDT
This is on 5.0, Win XP. But can try nightly, will report.

You can also try modified steps:
2. switch to other tab
3. enter panorama
4. planet.mozilla.org thumbnail is completely empty (white).
Now continue at original step 4.
Comment 3 Simona B [:simonab] 2011-07-01 05:02:39 PDT
WFM too on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110630 Firefox/7.0a1
Comment 4 :aceman 2011-07-01 12:22:20 PDT
OK, I have tried it on another machine with Windows XP, Nvidia card and HW acceleration enabled. I can't reproduce the problem there.
The machine that reproduces it has an Intel card and HW disabled (old driver).
Comment 5 :aceman 2011-07-11 08:26:00 PDT
I am now back at the original machine (with Intel), where this was spotted. Another facts:
the problem appears when the page is not fully loaded:
1. enter the url, press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. now the problem happens, continue at step 2 in comment 2.

When at step 4 loading is not interrupted and I wait until the page is fully loaded with all images, the thumbnail works fine.
Comment 6 :aceman 2011-07-11 12:51:07 PDT
With these steps I can reproduce it on another machine using Aurora 7, Linux.
Comment 7 :aceman 2011-08-09 12:40:16 PDT
Revised steps to reproduce (obsoleting comments 0,2,5):
1. enter the URL of long loading page (like planet.mozilla.org), press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. switch to another tab
5. enter panorama
6. planet.mozilla.org thumbnail is completely empty (white).
7. exit panorama by clicking on the thumbnail
5. in this step the thumbnail gets rendered correctly and zoomed in
6. scroll down the page
7. create a new tab
8. enter panorama
9. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position.
Comment 8 :aceman 2011-08-09 13:01:38 PDT
One more try at correct steps.

Revised steps to reproduce (obsoleting comments 0,2,5,7):
1. enter the URL of long loading page (like planet.mozilla.org), press enter
2. notice all the 'Loading data from <site>...' messages in the status popup, FF is downloading images.
3. press ESC or STOP while images are still loading.
4. switch to another tab
5. enter panorama
6. planet.mozilla.org thumbnail is completely empty (white).
7. exit panorama by clicking on the thumbnail
8. in this step the thumbnail gets rendered correctly and zoomed in
9. scroll down the page
10. create a new tab
11. enter panorama
12. see the thumbnail of planet.mozilla.org does not update to show the scrolled to position.
Comment 9 [:Aleksej] 2011-08-09 13:13:51 PDT
(In reply to aceman from comment #8)

Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110809 Firefox/8.0a1

> 3. press ESC or STOP while images are still loading.
> 4. switch to another tab
> 5. enter panorama
> 6. planet.mozilla.org thumbnail is completely empty (white).

Confirmed.

> 9. scroll down the page
> 10. create a new tab
> 11. enter panorama
> 12. see the thumbnail of planet.mozilla.org does not update to show the
> scrolled to position.

Confirmed.
Comment 10 :aceman 2011-08-09 13:47:06 PDT
Thank you for confirmation.

I will mark this bug NEW, however there exists bug 659594 (which may have the same cause) and bug 598435 which may have some relevance.
If anybody really see the real cause of this, duplicate or set dependence as needed.
Comment 11 :aceman 2011-08-20 02:37:07 PDT
Setting dependence on bug 659594 according to comments there.
Comment 12 Tim Taubert [:ttaubert] 2012-04-19 01:55:01 PDT
Fixed by bug 659594.
Comment 13 :aceman 2012-04-26 13:07:23 PDT
Thanks! Confirming fixed in recent nightlies.

Note You need to log in before you can comment on or make changes to this bug.