Closed Bug 665961 Opened 11 years ago Closed 11 years ago

ArrayBuffer does not respect prototype chain for property access.

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 665355

People

(Reporter: nsm, Unassigned)

References

Details

(Keywords: assertion, regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

Switching to inline slots and a delegate object breaks the prototype chain for properties set on the ArrayBuffer or prototype.

Reproducible: Always
First failure in commit b89374bc34ee
Comment on attachment 540857 [details] [diff] [review]
Fix: ArrayBuffer::obj_getProperty looks up the prototype chain.

I think this bug is fixed by the second patch in bug 665355, right? Can you move the tests here into that patch and mark this bug a dupe/fixed (your call)?
Attachment #540857 - Flags: review?(mrbkap)
fixed with second attachment on bug 665355
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 665355
You need to log in before you can comment on or make changes to this bug.