Last Comment Bug 666202 - import subscriptions and export subscriptions differ about opml extension
: import subscriptions and export subscriptions differ about opml extension
Status: VERIFIED FIXED
[duptome]
: polish
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: 5.0
: All All
: P2 minor (vote)
: Thunderbird 11.0
Assigned To: :aceman
:
Mentors:
: 516949 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 02:20 PDT by Matthew L Daniel
Modified: 2011-11-21 11:29 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
changes the order of file selection dialog filters to "OMPL, XML, All" (1.18 KB, patch)
2011-11-07 10:17 PST, :aceman
myk: review+
Details | Diff | Review

Description Matthew L Daniel 2011-06-22 02:20:02 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30
Build Identifier: 5.0b1

When one uses "Manage Subscriptions", "Export", TB will save a file with the .opml extension. 

However, when one uses "Manage Subscriptions", "Import", the file selection dialog does not show the same .opml file. It works fine if one types the filename manually, but this is unexpected behavior. 

Reproducible: Always

Steps to Reproduce:
1. Please see the description
Comment 1 :aceman 2011-11-06 14:10:07 PST
So what would be the expected behavior here?
This happens because the exported file is saved as .opml. But the import dialog has 3 filters for the file list. The default happens to be "XML files" so the previously created file is not directly visible. Changing the filter to "OPML files" or "All Files" makes the file visible.

So what is requested here? Should OPML be the default filter? Reorder the filter list to "OPML, XML, All" ?
Comment 2 Matthew L Daniel 2011-11-07 01:19:27 PST
(In reply to :aceman from comment #1)
> So what would be the expected behavior here?

The expected behavior is that if one exports from TB, one should be able to import from TB without having to alter something on the TB import dialog. The current setup seems to imply that TB feels .xml is the "primary" import type, and .opml is an alternative. However, the export emits .opml files.

> So what is requested here? Should OPML be the default filter? Reorder the
> filter list to "OPML, XML, All" ?

My suggestion is to choose from the most attractive of the following two choices:

1. Change the import filter order such that the default export format appears first
2. Change the export extension to be .xml to be aligned with the import file list
Comment 3 :aceman 2011-11-07 01:29:03 PST
I do not know what format the exported file actually is and what is the difference in content between OPML and XML.

I am able to code choice 1. from comment 2. But need confirmation from module owner that this would be accepted.
Ludovic, can you arrange it?
Comment 4 Ludovic Hirlimann [:Usul] 2011-11-07 01:39:33 PST
go for it.
Comment 5 :aceman 2011-11-07 10:17:17 PST
Created attachment 572514 [details] [diff] [review]
changes the order of file selection dialog filters to "OMPL, XML, All"
Comment 6 Myk Melez [:myk] [@mykmelez] 2011-11-09 14:13:23 PST
Comment on attachment 572514 [details] [diff] [review]
changes the order of file selection dialog filters to "OMPL, XML, All"

I double-checked the recommended file extension for OPML files, and it seems to be .opml, per the OPML 1 and 2 specs (which do not explicitly state this but do link to examples with that extension).

So this is the right fix and works well in my testing (although importing, exporting, and then re-importing an OPML file throws: "Either MyDailyFeeds.opml is not a valid OPML file or there was an error importing the file."; but that's a different bug!).
Comment 7 Myk Melez [:myk] [@mykmelez] 2011-11-09 14:14:15 PST
Ludovic: does this need super-review, or can it be committed?
Comment 8 :aceman 2011-11-10 00:15:34 PST
reply to Myk Melez [:myk] [@mykmelez] from comment #6)
> So this is the right fix and works well in my testing (although importing,
> exporting, and then re-importing an OPML file throws: "Either
> MyDailyFeeds.opml is not a valid OPML file or there was an error importing
> the file."; but that's a different bug!).

Maybe has problems with the fact that there already exist the same feeds.
Does importing into another profile show the same error?
Comment 9 Ludovic Hirlimann [:Usul] 2011-11-10 01:12:59 PST
(In reply to Myk Melez [:myk] [@mykmelez] from comment #7)
> Ludovic: does this need super-review, or can it be committed?

This can be committed as there is no API change we don't need sr.
Comment 10 Myk Melez [:myk] [@mykmelez] 2011-11-10 09:19:57 PST
(In reply to :aceman from comment #8)
> Maybe has problems with the fact that there already exist the same feeds.

Yes, I suspect that's the problem, as re-importing works after I unsubscribe from those feeds.
Comment 11 :aceman 2011-11-15 06:04:43 PST
(In reply to Myk Melez [:myk] [@mykmelez] from comment #6)
> So this is the right fix and works well in my testing (although importing,
> exporting, and then re-importing an OPML file throws: "Either
> MyDailyFeeds.opml is not a valid OPML file or there was an error importing
> the file."; but that's a different bug!).

Somebody filed this as bug 702527.
Comment 12 :aceman 2011-11-15 06:15:23 PST
*** Bug 516949 has been marked as a duplicate of this bug. ***
Comment 13 Mark Banner (:standard8) 2011-11-16 02:46:04 PST
Checked in: http://hg.mozilla.org/comm-central/rev/92b016a6e279
Comment 14 :aceman 2011-11-21 07:01:23 PST
(In reply to :aceman from comment #11)
> (In reply to Myk Melez [:myk] [@mykmelez] from comment #6)
> > So this is the right fix and works well in my testing (although importing,
> > exporting, and then re-importing an OPML file throws: "Either
> > MyDailyFeeds.opml is not a valid OPML file or there was an error importing
> > the file."; but that's a different bug!).
> 
> Somebody filed this as bug 702527.

Typo, it is 702542 -> 307629.

Note You need to log in before you can comment on or make changes to this bug.