Last Comment Bug 666587 - Context menus do not work on Dropbox
: Context menus do not work on Dropbox
Status: VERIFIED FIXED
fixed-in-tracemonkey
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla7
Assigned To: David Mandelin [:dmandelin]
:
Mentors:
http://www.dropbox.com
: 666095 666371 666733 (view as bug list)
Depends on:
Blocks: 640593
  Show dependency treegraph
 
Reported: 2011-06-23 07:29 PDT by Rodze
Modified: 2011-08-25 07:03 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
unaffected
+
fixed


Attachments
sample html zip (180.79 KB, application/x-zip-compressed)
2011-06-23 21:08 PDT, Alice0775 White
no flags Details
Patch (1.16 KB, patch)
2011-06-24 14:20 PDT, David Mandelin [:dmandelin]
no flags Details | Diff | Review
Patch 2, same as before, but removes tabs (2.34 KB, patch)
2011-06-24 14:23 PDT, David Mandelin [:dmandelin]
jwalden+bmo: review+
Details | Diff | Review

Description Rodze 2011-06-23 07:29:54 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110621 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:7.0a1) Gecko/20110621 Firefox/7.0a1

Context menus do not appear on right click or left click inside the Dropbox web file manager. Clarifying I don't mean Firefox's regular context menus, but Dropbox's special ones. Also, the check boxes aren't working either.

Reproducible: Always

Steps to Reproduce:
1. Log in to dropbox.com
2. Right click on any file, drop down button or check box


Actual Results:  
Nothing appears

Expected Results:  
Dropbox context menu should appear or check box should be checked/unchecked.

I'm not sure if this is a problem with Firefox or the site code.

Alice0775 found this possible window:

Works:
http://hg.mozilla.org/tracemonkey/rev/e59b1d2a2f79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110617 Firefox/7.0a1 ID:20110617173815

Fails:
http://hg.mozilla.org/tracemonkey/rev/9ced98ee3aa9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110618 Firefox/7.0a1 ID:20110618050724

Pushlog:
http://hg.mozilla.org/tracemonkey/pushl ... ed98ee3aa9

Triggered by:
9ced98ee3aa9 Tom Schuster — Bug 640593 - Remove Function.arity and other cleanup around function properties r=jorendorff
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-23 11:19:23 PDT
We need to track this for fx7, right?  Or did this make it into Fx6?
Comment 3 David Mandelin [:dmandelin] 2011-06-23 18:32:18 PDT
(In reply to comment #2)
> We need to track this for fx7, right?  Or did this make it into Fx6?

Aurora doesn't have that changeset. This might be a TE thing--the regressing changeset removed a nonstandard language feature that Chrome and IE both lack. Maybe some browser detect code or Firefox option needs to be fixed?
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-23 19:55:30 PDT
Can someone who has a dropbox account attach the relevant scripts here?
Comment 5 Alice0775 White 2011-06-23 21:08:58 PDT
Created attachment 541594 [details]
sample html zip

Zipped file ("Save Page As..." with "Web Page, complete")
Comment 6 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-23 21:47:05 PDT
Interesting.  Those scripts don't seem to mention .arity...
Comment 7 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-23 21:58:17 PDT
Nothing obvious jumps out at me here.  Tom?
Comment 8 David Mandelin [:dmandelin] 2011-06-24 14:20:40 PDT
Created attachment 541795 [details] [diff] [review]
Patch

We brought this up in a debugger and Jeff spotted the problem pretty easily. There were some unintentional cases to the control flow for .caller.
Comment 9 David Mandelin [:dmandelin] 2011-06-24 14:23:36 PDT
Created attachment 541798 [details] [diff] [review]
Patch 2, same as before, but removes tabs
Comment 10 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-24 14:24:55 PDT
Comment on attachment 541798 [details] [diff] [review]
Patch 2, same as before, but removes tabs

Review of attachment 541798 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 11 David Mandelin [:dmandelin] 2011-06-24 14:28:22 PDT
*** Bug 666733 has been marked as a duplicate of this bug. ***
Comment 12 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-24 18:53:31 PDT
Can we add tests for this?
Comment 13 Tom Schuster [:evilpie] 2011-06-26 13:03:31 PDT
Hey sorry about this... It wasn't clear to me that one of this calls behaves in such a strange way. Btw, i am 100% sure i commented in some other bug with the same issue and how to resolve it, shortly before camping.
Comment 14 Tom Schuster [:evilpie] 2011-06-26 13:48:47 PDT
The return false was of course plain stupid :(
Comment 15 Chris Leary [:cdleary] (not checking bugmail) 2011-06-27 11:40:18 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/d1cdf4295626
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.
Comment 16 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-06-27 14:26:17 PDT
Tom, can you add a test for this please?
Comment 17 David Mandelin [:dmandelin] 2011-06-27 14:26:58 PDT
*** Bug 666371 has been marked as a duplicate of this bug. ***
Comment 18 David Mandelin [:dmandelin] 2011-06-27 14:40:24 PDT
*** Bug 666095 has been marked as a duplicate of this bug. ***
Comment 19 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-28 14:36:24 PDT
Tests for this were landed as part of bug 667646 and bug 667538.
Comment 20 Asa Dotzler [:asa] 2011-08-11 14:45:25 PDT
dmandelin, looks like we need to get this into Aurora. Is that the case or is there some reason this is m-c only?
Comment 21 David Mandelin [:dmandelin] 2011-08-11 18:00:30 PDT
(In reply to Asa Dotzler [:asa] from comment #20)
> dmandelin, looks like we need to get this into Aurora. Is that the case or
> is there some reason this is m-c only?

AFAICT, it already made it to Aurora:

changeset:   72140:d1cdf4295626
user:        David Mandelin <dmandelin@mozilla.com>
date:        Fri Jun 24 14:26:00 2011 -0700
summary:     Bug 666587: revert accidentally changed control flow in fun_getProperty, r=jwalden
Comment 22 Trif Andrei-Alin[:AlinT] 2011-08-25 07:03:39 PDT
Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0

I have followed your steps on dropbox.com and it seems this issue has been fixed, since right-clicking on any item shows the context menu.
And also left-clicking on checkboxes works.
Setting resolution to VERIFIED FIXED.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.