Closed Bug 666600 Opened 9 years ago Closed 7 years ago

Add an option in preferences to set the default zoom level

Categories

(Firefox for Android :: Toolbar, enhancement)

All
Android
enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: aakashd, Assigned: kats)

References

Details

(Keywords: productwanted, uiwanted, Whiteboard: [Input][parity-stock])

Attachments

(1 file)

Users are asking for a way to set a default zoom level via an option in the preferences panel in Input:

https://input.mozilla.com/en-US/search?q=default+zoom+page&product=mobile&version=--

We don't have a bug on this, so filing it here.
Link seems broken. Aakash - what's your interpretation of this request? What is the use case?
Indeed it is, here's the real link: 

https://input.mozilla.com/en-US/?q=default+zoom+page&product=mobile&version=--

The use case is about having full control over the zoom level of the page that's loaded (e.g. showing the full page vs. a zoomed-in version of the page on load).
So where exactly is the zoom option?
There are still recent comments requesting this feature; we should probably add it. I like Frederik's suggestion at https://bugzilla.mozilla.org/show_bug.cgi?id=817262#c13 of having a mode that renders the page zoomed in and with font inflation turned off.
Component: Panning/Zooming → Graphics, Panning and Zooming
Keywords: uiwanted
OS: All → Android
Product: Fennec → Firefox for Android
Version: Firefox 5 → Trunk
Whiteboard: [Input] → [Input][parity-stock]
Requesting tracking for 20 since this behaviour makes a lot of sense on smaller screens, such as the QVGA screens we may or may not be supporting.
Tracking is for things that would block release, or regressions/crashes we are trying to get fixes for into a particular release.  Perhaps you want to flag this for tracking-fennec if this enhancement is desired for a targeted release, but there's no reason for Release Management to track this issue - esp. with no assignee and no product driver.
tracking-fennec: --- → ?
Can we get more details about how this would work and why we need it?
Keywords: productwanted
How it would work is basically having an option in the preferences that changes the default zoom to be 1.0 instead of fitting the page width to screen. Right now when the page loads we render the page zoomed out; to do anything useful with the page you have to zoom in first, and this would solve that problem.

In particular this would be very nice to have on small-screen devices because (a) it's harder to pinch zoom on tiny screens and (b) rendering the page zoomed out is useless if there aren't enough pixels to really show the content properly - all you see is blurry lines instead of text.
Karen when you in weigh in here, please renom if appropriate
tracking-fennec: ? → ---
Flags: needinfo?(krudnitski)
I'd like to think through the behaviour some more. I'd like to understand what setting zoom level to 1.0 looks like if you surf to multiple different websites; what happens on mobile websites vs desktop websites. 

Is there a build we could play with to take a look at? As an aside, if we think this is a readability issue, we could include this in Fx22 which is our 'readability' theme and ensure we implement and test appropriately.
Flags: needinfo?(krudnitski)
I'd like to land this patch regardless since it doesn't change any default behaviour. It adds a pref to control the default fallback zoom level. By "fallback" I mean it doesn't override any meta-viewport settings or the 1.0 zoom we default to in case of mobile/HandheldFriendly pages. It should be sufficient to handle the cases people were asking for, and we can expose it via the settings UI if product so desires.

Try build in progress at https://tbpl.mozilla.org/?tree=Try&rev=83079117ec37 - once that's done, load the build and set browser.viewport.defaultZoom to 1000 in about:config to see the behaviour people were asking for.
Assignee: nobody → bugmail.mozilla
Attachment #694556 - Flags: review?(mark.finkle)
Comment on attachment 694556 [details] [diff] [review]
Add a pref for default fallback zoom level

Seems safe enough. As you suggest, we can talk more about exposing this as a visible setting.
Attachment #694556 - Flags: review?(mark.finkle) → review+
Landed on inbound but leaving open until we decide whether or not to expose this via UI.

https://hg.mozilla.org/integration/mozilla-inbound/rev/7a475450b0cd

(In reply to Karen Rudnitski from comment #12)
> Is there a build we could play with to take a look at?

The builds are ready now at [1] (for ARMv7) and [2] (for ARMv6). Just set the browser.viewport.defaultZoom pref to 1000 and load some pages. You shouldn't need to restart the browser after changing the pref.

[1] http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-83079117ec37/try-android/fennec-20.0a1.en-US.android-arm.apk
[2] http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-83079117ec37/try-android-armv6/fennec-20.0a1.en-US.android-arm-armv6.apk
Flags: needinfo?(krudnitski)
Whiteboard: [Input][parity-stock] → [Input][parity-stock][leave open]
The patch and setting works but the activated "Pinch to reflow text" option should also reflow the text when browser.viewport.defaultZoom is not -1 (default) because otherwise you still have to scroll to the left/right. 
The whole purpose of this feature (from my point of view) is to use Firefox on smartphones on complex websites easily operated and that means to scroll only up and down (if possible).
Take a look at the stock browser if overview mode is disabled for comparison.
A visible option for the setting would be nice, too!
Flags: needinfo?(krudnitski)
(In reply to Frederik Niedernolte from comment #17)
> The patch and setting works but the activated "Pinch to reflow text" option
> should also reflow the text when browser.viewport.defaultZoom is not -1
> (default) because otherwise you still have to scroll to the left/right. 

Do you mean the page should be reflowed right on page load to fit in the browser screen?

> Take a look at the stock browser if overview mode is disabled for comparison.

Just to make sure I'm seeing the same thing, which device and Android version are you using?

> A visible option for the setting would be nice, too!

Hence the needinfo to Karen, who will make that call.
Flags: needinfo?(krudnitski)
Yes, the page should be reflowed right on page load to fit in the browser screen if the option is turned on. 

Nexus 4, Android 4.2.1 

You can see what I mean in the stock browser If you go to Settings > Advanced and disable the option "Open pages in overview" and turn on the option "Auto-fit pages". There is also another option for the default zoom which would be browser.viewport.defaultZoom in Firefox.
I'm leaving it to UX/product to decide what we want to do here.
Flags: needinfo?(ibarlow)
Thanks, Kats, for preparing the handsets with the builds on it for comparison. 

I've done a fair bit of playing around today on the builds and done a fair bit of thinking on the topic, as well as talked it through with Ian.

I do see some value in having the pref defaulted to a zoom level that is readable on desktop sites, especially for our lower-end phones. However, simply surfacing the pref at the UI level is not so simple to implement correctly (using the right language, finding the most appropriate zoom level, etc). We don't want to just be expanding our settings menu on all possible user-configurable items.

Therefore the following approach is one I would be comfortable proceeding with:
- keep the setting in about:config so that it is possible to set for those with the know-how and desire for this pref
- if we can, have a corresponding SUMO article on the topic
- add this to a wider 'advanced settings' menu discussion that is on Ian's to-do list on how we deal with many of these preferences that are requested (and provide value) so that we can create an understandable, scalable and intuitive menu structure -> of paramount to our larger user experience
- solicit feedback to see what *is* a good default pref (because I'm not sure it's simply 1:1 myself!) for those who are using it

In a nutshell, don't change the pref to one that is zoomed in and don't add this to our current settings menu. BUT have it in about:config so it IS possible to change for those who really want this today, and we WILL have this added to the wider 'advanced settings' menu discussion to determine how best (and if) to surface this up to the more visible UI.

Doable?
Flags: needinfo?(krudnitski)
Sounds good to me. I guess we can close this bug and revisit it once it comes back up from Ian's 'advanced settings' to-do list.

Closing as FIXED since there was a patch that landed here.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ibarlow)
Resolution: --- → FIXED
Whiteboard: [Input][parity-stock][leave open] → [Input][parity-stock]
What about the page should be reflowed right on page load to fit in the browser screen if the option is turned on? 
I think this should at least be added to finish it "correctly" for advanced users if browser.viewport.defaultZoom is not -1.
Please file a new bug for that and CC me. It shouldn't be too much work to implement that as a preffable behaviour, but implementation-wise it is separate from the default zoom and so should be handled in a separate bug.
You need to log in before you can comment on or make changes to this bug.