Closed Bug 666674 Opened 9 years ago Closed 9 years ago

Ajax broken using Telerik Rad Grid - RadControls 'Prometheus' for ASPNET Q3 2007

Categories

(Firefox :: General, defect)

5 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 666955

People

(Reporter: herriedm, Unassigned)

References

()

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; .NET4.0C; .NET4.0E)
Build Identifier: Firefox 5

Ajax does not work in Rad grid linkbuttons.
I believe this calls a callback function.

Reproducible: Always


Actual Results:  
Does not work... just hangs.
Version: unspecified → 5 Branch
Please provide steps to reproduce and if you need a login on your page you should provide a different testcase.
Create account in Fleetmentor.com

Go to Employees..https://www.fleetmentor.com/EmployeeList/EmployeeList.aspx
Add Employee... you probably will have to use IE 8 to do this.

Go back to EmployeeList.aspx, Click on link of employee name in the Telerik Radgrid. It should do a postback and go to a page to enter data.  However it just hangs...

If i remove ajax from this page, it will work... hope that helps.
Any errors in the error console? Can you provide a reduced test case?
Sorry I dont see any.  It just throws the error on response.redirect and then it just goes to the same page where the link button was.

I see more and more people having this problem. Its affecting quite a few sites.. from what im seeing on the forums..

Why would response.redirect not work?
(In reply to comment #4)
> Sorry I dont see any.  It just throws the error on response.redirect and
> then it just goes to the same page where the link button was.
> 

What error?

Please provide a public URL (that doesn't require a registration/login) or best of all, a reduced test case.
No error in the console.

Just ASP.net response.redirect is ignored when it's called (server-side) inside a RadAjax panel.
Duplicate of 666955 (or visa versa)?  Anyway, see my comments there...
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666955
Depends on: 666604
Blocks: 583514
You need to log in before you can comment on or make changes to this bug.