Caret appears when non-focused entryfield control enabled

VERIFIED DUPLICATE of bug 74145

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 74145
18 years ago
18 years ago

People

(Reporter: Jeffrey S. Kobal, Assigned: rods (gone))

Tracking

Trunk
mozilla0.9
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In layout/html/forms/src/nsGfxTextControlFrame2::AttributeChanged, the Caret is 
enabled (which makes it visible and blinking) in the entryfield when the field 
is enabled or made visible, even if that field doesn't have input focus.

Failing scenario:

1. In Composer, select Format->List->List Properties
2. Change List Type to Numbered List
3. Click in Start At field to put input focus there (blinking cursor appears)
4. Change List Type to None (Start At field is now disabled)
5. Change List Type back to Numbered List

At this point, the Numbered List field still has input focus, but the blinking 
cursor appears in the Start At field nevertheless.  You can't type into that 
field, even though it looks like you can.

(Above is the scenario to reproduce this on Windows.  For some reason, this 
fails immediately on OS/2, without needing steps 1-4.)

Comment 1

18 years ago
I think this is a dup of bug 39999.

Comment 2

18 years ago
Reassigning to rods.
Assignee: karnaze → rods

Comment 3

18 years ago


*** This bug has been marked as a duplicate of 74145 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified on Mac mozilla optimized build from 4am today.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla0.9
You need to log in before you can comment on or make changes to this bug.