Last Comment Bug 667075 - Safe Browsing shouldn't use SQL queries to generate random numbers
: Safe Browsing shouldn't use SQL queries to generate random numbers
Status: RESOLVED FIXED
[inbound]
:
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Firefox 8
Assigned To: Gian-Carlo Pascutto [:gcp]
:
Mentors:
Depends on: 691364
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 15:00 PDT by Gian-Carlo Pascutto [:gcp]
Modified: 2014-05-27 12:25 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 Use nsIRandomGenerator instead of querying SQLite. (5.50 KB, patch)
2011-07-28 04:55 PDT, Gian-Carlo Pascutto [:gcp]
dcamp: review+
Details | Diff | Review

Description Gian-Carlo Pascutto [:gcp] 2011-06-24 15:00:59 PDT
nsresult nsUrlClassifierStore::RandomNumber(PRInt64 *randomNum) uses queries to SQLITE to generate random numbers.

This perversion exists because of bug 419739, but that seems to have been fixed by bug 607115 now.

I'm going to get rid of this if only because it makes my eyes hurt.
Comment 1 Gian-Carlo Pascutto [:gcp] 2011-07-28 04:55:35 PDT
Created attachment 549075 [details] [diff] [review]
Patch v1 Use nsIRandomGenerator instead of querying SQLite.

http://tbpl.mozilla.org/?tree=Try&rev=b913d9c2915e
Comment 2 Marco Bonardo [::mak] 2011-08-01 08:00:40 PDT
http://hg.mozilla.org/mozilla-central/rev/b4165ae3685f

Note You need to log in before you can comment on or make changes to this bug.