Closed Bug 667242 Opened 8 years ago Closed 3 years ago

grossly inflated spacing in printed page when harfbuzz is disabled

Categories

(Core :: Printing: Output, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: al_9x, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: 

from:
http://forums.mozillazine.org/viewtopic.php?f=38&t=2158847&p=10937255#p10937255

a couple of comparisons:
http://img87.imageshack.us/img87/492/harfbuzzbug.png
http://img820.imageshack.us/img820/4046/harfbuzz.png

pages where the problem can be seen:
http://www.sudokuteam.com/sudoku_schwer.php
http://sudoku.at/sudoku_extraschwer.php
(presumably) all Bugzilla bug pages
e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=639185
http://www.mozilla.com/en-US/firefox/central/


Reproducible: Always

Steps to Reproduce:
1. xp sp3, Fx 5.0, new profile
2. set gfx.font_rendering.harfbuzz.scripts=0, restart
3. go to a problem page
4. print to pdfcreator, a physical printer should show the same symptoms
Version: unspecified → Trunk
I had this problem before, but had never realised that this could have had anything to do with it... I was convinced my PDF printer was simply broken. 

I had this same problem in Windows XP on Firefox 4 (not 5). Occasionally it did do it correctly though, and sometimes the strange spacing only started in the middle of a page. 
Since then though I've reinstalled my computer with Windows 7, so I can not check any potential solutions.
Happens on seemingly all http://www.amazon.com/ pages.

Why is this being ignored?
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110816 Firefox/8.0a1 ID:20110816100414.

As a Checkmark this must have been introduced sometime post Bug 569531.

@al_9x@yahoo.com: Reports against "non-default Settings Bugs" usually tend to get lower Priority (understandably).
Status: UNCONFIRMED → NEW
Ever confirmed: true
xp users (~50% of windows, globally) have had messed up tahoma (default chrome font) rendering since Fx4 (Bug 639185), which necessitates turning off harfbuzz, if you don't want to be distracted by wacked kerning, that was never intended for tahoma

that bug is still unconfirmed, please new it.  If it's fixed:

> Maybe we should figure out some way to override it without disabling
> harfbuzz altogether (which means losing lots of more advanced font features).

the need to disable harfbuzz will be eliminated.
Maybe a new Report for an Implementation of a White/Blacklist regarding the Kerning/Harfbuzz Stuff of certain Fonts should be created and all those already filed Reports should block it, no?
(In reply to XtC4UaLL [:xtc4uall] from comment #6)
> Maybe a new Report for an Implementation of a White/Blacklist regarding the
> Kerning/Harfbuzz Stuff of certain Fonts should be created and all those
> already filed Reports should block it, no?

This bug should not block on a kerning blacklist.  Having a blacklist would eliminate the need to disable harfbuzz, but it would not resolve bugs stemming from disabled harfbuzz (this, Bug 672456)

Bug 639185 and Bug 621030 are dupes.  One of them should be closed, and the other devoted to implementing the kerning exception for Tahoma or a more general kerning blacklist.  The real issue however, is getting someone (Jonathan Kew ?) to work on this.
Blocks: 690917
To help in diagnosing exactly what's going wrong here, please try going to about:config and setting the preference "browser.display.auto_quality_min_font_size" to zero. Does that make the problem go away on your system?
(In reply to Jonathan Kew (:jfkthame) from comment #8)
> To help in diagnosing exactly what's going wrong here, please try going to
> about:config and setting the preference
> "browser.display.auto_quality_min_font_size" to zero. Does that make the
> problem go away on your system?

yes
Those who are experiencing this bug: Please test with the tryserver build at https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jkew@mozilla.com-9d3ee39d7727/try-win32/ and confirm whether it fixes the problem.

(See bug 672456 for the patch being tested.)
(In reply to Jonathan Kew (:jfkthame) from comment #10)
> Those who are experiencing this bug: Please test with the tryserver build at
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jkew@mozilla.com-
> 9d3ee39d7727/try-win32/ and confirm whether it fixes the problem.
> 
> (See bug 672456 for the patch being tested.)

confirmed
Just got bit by this big time, wasting Mozilla developer's time (see latest comments in Bug 454532).  The tryserver URL in this bug's comment 10 returns 404.  Bug 672456 comment 11 indicates this one-line fix was committed in late October, while Firefox 9.0 just came out a few days ago.  Which branch was this committed to?  Why wasn't this picked up by 8.0 or 9.0?  Please shed some light on this situation.
HarfBuzz cannot be disabled anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.