When clicking in the Location Bar, the http:// should reappear

RESOLVED WONTFIX

Status

()

Firefox
Location Bar
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: teoli, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-opera])

(Reporter)

Description

6 years ago
With bug 665580, the http:// part of an address is no more displayed (only for the http protocol).

This make one use case more difficult: switching from http to https, which was previously done with adding the s to the protocol, needs now to type the whole https:// string.

Opera solves it by re-adding the http:// in front of the URL when the user clicks in the address bar.
Why is this useful? Seems to me like it would result in confusingly jumpy UI.
(Reporter)

Comment 2

6 years ago
Opera's implementation is not jumpy. Their identity button is different than ours. Even for http sites, it is a large button with an icon (which is not a favicon, but a small round "world" icon) followed by a text, "Web").

When clicking on the Address bar, the text of the URL doesn't move at all (which would have made it jumpy, I agree). The identity button shrinks hiding the text (only the "world" icon is still visible), uncovering the http:// beneath.

Advantages I see:
1) It solves the http->https by editing one single char in the URL (minor use case)
2) It makes Ctrl-C more obvious: when we copy the URL we see the URL we are copying (Firefox adds automatically the missing http:// to the clipboard data when it detects copying. The discrepancy between what is highlighted and what is copied may be slightly confusing for some users)
3) It fits in a bigger scheme:
Opera also hides the https:// protocol. In that case the identity button has a lock icon and the "Secured" text (which is not good btw as crypted + authenticated doesn't mean secured, but Firefox do it right now). The behaviour is the same as the one of the http protocol: when clicking on the address bar, the button shrinks too, showing the previously hidden https://.

Similarly file:// is hidden (a computer icon + "Locale" as text in the identity button), ftp:// too (but it is cannot be distinguished from an http:// site).

Comment 3

6 years ago
By the way Chrome / Chromium displays only the https:// protocol

I mean, it was really better it was before - not hiding anything, there are no benefits for the user. It creates only problems. Opera "world"-icon is absolutly useless. Opera hides the url-parametres as well, which can be disabled via opera:config. By ftp:// the Opera's "world"-icon says web, I see this as well as wrong.

Please think again about this wrong idea about hiding information. I expect you read this: http://blog.babelzilla.org/2011/06/25/is-the-death-of-the-address-bar-programmed/

Comment 4

6 years ago
if hiding http:// is justified with only "user-friendly" argument, I request that mozilla defines the meaning of "user" and "friendly".

I am not among one of these users and certainly felt not friendly to me.

Comment 5

6 years ago
I agree with Ageios!

My friends do not make me things more difficult, than they were before!

User is everybody who uses a program, even the hacker is sometimes a user, even of his own product! THRON: IT'S A USER! KILL HIM! :O But user-friendly!!!

Updated

6 years ago
blocking2.0: --- → ?

Comment 6

6 years ago
Gguys -> Please read an follow https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

If you want to show your support for a bug, just use the Vote button above (like I have done)

Please do not set flags just because you can.
blocking2.0: ? → ---
OS: Mac OS X → All
Hardware: x86 → All

Comment 7

6 years ago
We should not change the position of characters when focusing the location bar. Editing the protocol like that is not a use case for which we should optimize. Good UI shouldn't rely on implementation model like that.

In the future, we may implement a one-click toggle to switch to SSL.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
Duplicate of this bug: 668203

Comment 9

6 years ago
Either this needs to be fixed or maybe this should be handled in a separate bug, but this change breaks the url bar when dealing with localhost or computer names.

For example:

Type: http://localhost/page with spaces.html
Hit enter
Page loads
Focus location bar
Change url to localhost/page with spaces 2.html
Hit enter
Google search loads

This worked fine before because the http:// is apparently required for these URLs when spaces are present.  Maybe the parsing of the URL needs to be fixed instead though.
Can you please file a separate bug for that (and CC me)?

Comment 11

6 years ago
Frank: is there a bug filed for implementing a one-click toggle to switch to SSL? At least there is browser.urlbar.trimURLs which can be switched, if you find the switch, for those of us who think this is a bad implementation.

Comment 12

6 years ago
Frank: is there a bug filed for implementing a one-click toggle to switch to SSL? At least there is browser.urlbar.trimURLs which can be switched, if you find the switch, for those of us who think this is a bad implementation.

Updated

6 years ago
Duplicate of this bug: 687571

Comment 14

4 years ago
What's curious to me is mobile implements this correctly!  When you focus in the url bar, it displays the whole url.
This despite often having a screen that is a tiny fraction of the size of the desktop screen.

I noticed this on the drive to work after having spent quite some time on a remote debug phone call w/ boss who couldn't access one of the test sites.  Turns out he didn't realise http:// wasn't "already there" for a non-standard port.

Implement the opera behaviour!  Will improve performance of url bar, eliminate still existing bugs when people edit urls, greatly simplify url bar code by tossing all the trimurl magic, and not confuse users.

Mobile displays full URL on focus, so should desktop!
You need to log in before you can comment on or make changes to this bug.