When focus is on the URL bar, insert http:// as appropriate

RESOLVED DUPLICATE of bug 667271

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 667271
6 years ago
5 years ago

People

(Reporter: Cww, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #668019 +++

When we removed http from URLs, we got a bunch of complaints. One thing we should address is that users can't switch easily between http and https because they can't just add an S

http://input.mozilla.com/en-US/opinion/2371452
http://input.mozilla.com/en-US/opinion/2324152
http://input.mozilla.com/en-US/opinion/2319559
 
Also, not having the http there causes some other problems when editing the URL bar and may break extensions:

http://input.mozilla.com/en-US/opinion/2385594
http://input.mozilla.com/en-US/opinion/2377766
http://input.mozilla.com/en-US/opinion/2375238
http://input.mozilla.com/en-US/opinion/2372560

Updated

6 years ago
No longer depends on: 668019

Updated

6 years ago
tracking-firefox7: + → ---
It would be rather janky to have the URL bar value change when you focus it (clicking to select text would be very broken, for example). We could try to mitigate with smooth transition or something, but that would be rather complicated to implement.
Yeah, I don't think we're going to do this.
Don't know if it's a good idea but Opera 11.5 has a badge space that they reduce when focusing. So the rest of the URL stays at the same place, they make room on the left to show the http part.

Comment 4

6 years ago
You, guys, are trying to solve a problem that has been created by your solution to a nonexistent problem. Just display the protocol at all times, and that's all. It was good.

Comment 5

6 years ago
I fully agree with #4. Not showing the protocol in a desktop browser where horizontal space is not *that* valuable (hey, most people use widescreens and nowadays URLs are often "friendly" and not overly long anyway (unless you use intershop etc ;))) is a horrible misfeature that will just make users think the protocol isn't part of the address.

Today I saw a user on stackoverflow.com who wondered why his link to www.google.de (without http://) didn't work.... So this feature might actually make users dumber. :/

Updated

6 years ago
No longer blocks: 665580
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667271

Comment 7

5 years ago
Heh. Adrian, I also blame this Chrome misfeature also for increase in broken "relative" links online.
Stuff like http://www.newscientist.com/article/dn22245-silent-spring-didnt-condemn-millions-to-death.html where the article links relatively to a remote site mid-article.  Presumably an omitted http://
You need to log in before you can comment on or make changes to this bug.