Closed Bug 667399 Opened 8 years ago Closed 7 years ago

RealPlayer G2 LiveConnect plugin crash

Categories

(Core :: Plug-ins, defect, critical)

2.0 Branch
x86
All
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cwdjrxyz, Unassigned)

References

()

Details

(Keywords: crash, regression, reproducible)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

For Firefox 4 and 5, but not 3 series, the Real Player 12.0.1.647 Live-connect plugin crashes so video not shown and reloading page as instructed fails on Vista 64-bit.

Try my page at http://www.cwdjr.net/video7/RoscoeGreetings.php . Click on the Real button. This page works for a Real video on Firefox 3 series and about 7 other current browsers. The Real player and plugins are up to date. The Vista 64-bit OS is up to date. On Firefox 4 and now 5, instead of a Real video you get a screen that says that the RealPlayer Live Connect-Enabled (32-bit plugin has crashed. The instruction to reload the page and try again does not work. There is no link to report the problem as is usual on most other problems of this sort. Turning the plugin off just removes the space reserved for the video. I have to revert to the Firefox 3 series to solve this problem. Doing clean re-installs of the most recent Real player and Firefox 4 or 5 does not help. 


Actual results:

On Firefox 3 series, a Real video displays correctly. On Firefox 4 and now 5 series, only an error message saying a Real plugin crashed appears. There are no problems on about 7 other current popular browsers. 


Expected results:

The Real video should have appeared.
Build ID: Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110626 Firefox/7.0a1

This issue has been reported some time ago. Please have a look at bug 572801. Thanks for the notice.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572801
Uh, in this report it is the plugin which crashes, whereas bug 572801 is the browser crashing. I'm not sure they reflect the same issue. The fact that the plugin version is wildly different also makes me skeptical this is a real dupe. Andrei, do you have particular info not in this bug that made you decide this was a dupe?
Severity: normal → critical
Status: RESOLVED → REOPENED
Component: General → Plug-ins
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → plugins
Resolution: DUPLICATE → ---
> Andrei, do you have particular info not in this bug that made you
> decide this was a dupe?

No, at the time I duped it I thought it was the same issue as the one reported in bug 572801, but it does seem different. thanks for the notice
Status: REOPENED → NEW
Can you provide the two crash IDs (plugin and browser sides)?
OS: Other → Windows 7
Hardware: All → x86
Version: 5 Branch → 2.0 Branch
(In reply to Scoobidiver from comment #4)
> Can you provide the two crash IDs (plugin and browser sides)?

Since this problem was reported, we are up to the 10 series of Firefox and I no longer can obtain crash IDs for versions of Firefox I no longer have. If you go to http://www.cwdjr.net/video7/RoscoeGreetings.php and select Real, you will find additional information for several newer versions of Firefox. In brief, the problem was solved for some newer versions of Firefox and now is back for Firefox 9 and 10 series.

It seems that Firefox should test for major media problems on at least more recent versions of widely used OSs before they release any new version of Firefox. For example for Windows OSs, tests should be made on 32 and 64 bit versions of XP, Vista and 7. This sort of problem should never be let through for a new version of a browser. For my personal browser use, I have little problem, since I usually have the latest versions of Firefox, IE, and Opera or Safari for Windows up at the same time. It only takes clicking on a tab for another browser and entering the url for the problem page. However some only run one browser, such as Firefox. Thus so they can view the video I mention several other browsers that do not have the problem and how to download the video to your computer rather than stream it online.
Summary: For Firefox 4 and 5, but not 3 series, the Real Player 12.0.1.647 Live-connect plugin crashes so video not shown and reloading page as instructed fails on Vista 64-bit. → RealPlayer G2 LiveConnect plugin crash
Duplicate of this bug: 709029
Crash Signature: [@ clntcore@0x9ceac]
OS: Windows 7 → All
(In reply to cwdjrxyz from comment #0)
> Steps to reproduce:
> Try my page at http://www.cwdjr.net/video7/RoscoeGreetings.php . Click on
> the Real button. This page works for a Real video on Firefox 3 series and
> about 7 other current browsers. The Real player and plugins are up to date.
> The Vista 64-bit OS is up to date. On Firefox 4 and now 5, instead of a Real
> video you get a screen that the RealPlayer Live Connect-Enabled (32-bit plugin has crashed.

Apparently works, but crashes if switching tabs.
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0b4
As of the 13 update, there is still the same crash problem on Firefox, at least for the Vista 64-bit OS. Thus I have completely changed the code for Real video on the given url of http://www.cwdjr.net/video7/RoscoeGreetings.php . The old code used a .rpm link to bring up the Real player console that plays the actual .rm Real video. This works for nearly all past and recent major browsers, except for many Firefox versions for the past few years now. I have had no response from this or other Firefox related sites that would indicate that Firefox can solve the problem, even though some fairly recent versions have not had the problem.

I now use the smil xml language to at least solve the problem for my own web pages. The recent and even fairly old official versions of Real have a smil reader built in. This is important, because most browsers do not directly support smil or many other xml languages for that matter. Thus one can write a smil xml page to be shown on the Real player and it works. Of course if you do not have an official Real player installed, this may not work because various unofficial players that claim to play real media may or may not have a smil module built in.

The main page of the given url is just mainly a form to tell the php what to do. It eventually links to a smil page if the Real player is selected. To see the xml smil code, go to http://www.cwdjr.net/video7/SMILroscoeonly.txt . The old code used a .rpm link to bring up the Real player console that plays the actual .rm Real video. This works for nearly all past and recent major browsers, except for many Firefox versions for the past few years now. I have had no response from this or other Firefox related sites that would indicate that Firefox can solve the problem, even though some fairly recent versions have not had the problem.

I now use the smil xml language to at least solve the problem for my own web pages. The recent and even fairly old official versions of Real have a smil reader built in. This is important, because most browsers do not directly support smil or many other xml languages for that matter. Thus one can write a smil xml page to be shown on the Real player and it works. Of course if you do not have an official Real player installed, this may not work because various unofficial players that claim to play real media may or may not have a smil module built in.

The main page of the given url is just mainly a form to tell the php what to do. It eventually links to a smil page if the Real player is selected. To see the xml smil code, go to http://www.cwdjr.net/video7/SMILroscoeonly.smil . Details of php code are much too long to show in detail. Over 20 modules are linked together using mostly php to build the complete page.
Instead of using a Real rm video file it is possible that a real rmvb variable rate Real file would not have the problem. I migh re-encode the video to .rmvb(variable bit rate) at some point to see if this makes any difference.
Another page that has the problem is http://www.cwdjr.net/flash3/catfightclips.php . Click on the real button if you have an official Real Player installed. This has the same Real Player crash as the original Roscoe Greetings page had before it was modified to use SMIL XML to make work on Windows Home Vista 64-bit. I then viewed this page on Windows Home 32-bit XP and the page worked properly. At first the 32-bit XP was using Firefox 3.5.19 and an old version of official Real Player. I next updated Firefox to 13.0.1, and the page continued to work. I then updated the Real Player to 15.0, and the page continued to work.

To start to solve the problem for the Real Player crash when online using the .rpm extension to bring up the Real console module, one needs to view the page on Windows XP, Vista, and 7 in all versions of each to see if any other versions other than Vista 64-bit Home have the problem. Then those who write the code for Firefox would find it more simple to find the problem code in some versions of Firefox for some OSs and fix it. There is no problem on recent versions of other browsers including Opera, Chrome, Safari for Windows, IE9, K-Meleon, and Flock. 

When updating the Real player on the XP I noticed that Real is pushing Google Chrome, not Firefox. I wonder why?
(In reply to cwdjrxyz from comment #9)
> When updating the Real player on the XP I noticed that Real is pushing
> Google Chrome, not Firefox. I wonder why?
For the same reason Adobe pushed Chrome when updating Flash: Google pays well.
Can someone please confirm if this is still an issue with Firefox 15 Beta and RealPlayer 15?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #11)
> Can someone please confirm if this is still an issue with Firefox 15 Beta
> and RealPlayer 15?

I confirm this on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0b5 using Real player 15.0.6.14
1. Open http://www.cwdjr.net/flash3/catfightclips.php (comment 9)
2. Click Real button, then click play button
3. Open a new tab
4. Go back to real video tab

Actual results: RealPlayer LiveConnect plugin has crashed

Note: The link in comment 0 (http://www.cwdjr.net/video7/RoscoeGreetings.php) now redirects to a SMIL page that FF cannot open (open/save file dialog appears)
Thanks for confirming Paul. I wonder if you could try to track down some older Realplayer versions to see if this regressed on their end at some point. On our end, this bug goes all the way back to Firefox 3.

Kev, I'm wondering if there's something we can do in terms of outreach to Real Networks. I don't see much point in keeping this bug open any longer if nobody on our end or theirs is going to work on it.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #13)
> Thanks for confirming Paul. I wonder if you could try to track down some
> older Realplayer versions to see if this regressed on their end at some
> point. On our end, this bug goes all the way back to Firefox 3.
> 
> Kev, I'm wondering if there's something we can do in terms of outreach to
> Real Networks. I don't see much point in keeping this bug open any longer if
> nobody on our end or theirs is going to work on it.

From answers to your question, the problem still seems to be alive on at least some versions of Microsoft OSs. We still need to look using all versions of Vista, 7, and XP to see the complete scope of this problem. I know that this problem has not occurred on an old 32 bit Home XP, even after it had Firefox and Real updated to the most recent stable versions - I do not install beta versions of browsers. If others can check on at least Vista 32-bit home and both 32 and 64 bit versions of Windows 7, if the problem happens only on 64-bit versions, then it might be more simple to locate the problem code. Problems with 64-bit Windows OSs have been rather common for media programs in the past, but these usually get corrected after a time on various browsers, media players etc.

Your suggestion to contact Real might be helpful, especially if the scope of the problem for recent Windows OSs is determined. Since some Microsoft OSs are involved with Firefox installed and the Real player used, I am not confident that Microsoft, If consulted, would be willing to spend much time on the issue, since the problem with Real only happens on Firefox.

Until this problem is solved, I think the bug should be kept open for even several years , and even after Firefox is updated to a version without the problem, older versions of Firefox back a few versions should be corrected as long as large numbers of the older browser versions are still in use by many.
On Firefox 11 with the last version of RealPlayer 15.0.6.14 crashes but a message said: "El plugin RealPlayer(tm) G2 LiveConnect-Enabled (32-bit) dejó de funcionar. Reporte no disponible. Recargar la página para volver a intentarlo."
(In reply to Paul Silaghi [QA] from comment #12)
> I confirm this on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0)
> Gecko/20100101 Firefox/15.0b5 using Real player 15.0.6.14
> 1. Open http://www.cwdjr.net/flash3/catfightclips.php (comment 9)
> 2. Click Real button, then click play button
> 3. Open a new tab
> 4. Go back to real video tab
> 
> Actual results: RealPlayer LiveConnect plugin has crashed

This no longer reproducible with the latest Real Player 16.0.1.18.
Tested on FF 21b6, 23.0a1 (2013-05-01)
Status: NEW → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.