Last Comment Bug 667516 - touch.facebook.com breaks when panning
: touch.facebook.com breaks when panning
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: Panning/Zooming (show other bugs)
: Firefox 7
: ARM Android
: P1 normal (vote)
: Firefox 8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-27 10:36 PDT by Kevin Brosnan [:kbrosnan]
Modified: 2011-08-24 07:47 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot displaying the issue (92.58 KB, image/png)
2011-06-27 11:03 PDT, Kevin Brosnan [:kbrosnan]
no flags Details
Issue on Droid X (85.57 KB, image/png)
2011-07-10 10:22 PDT, CoJaBo
no flags Details
SUMO screenshot (69.52 KB, image/png)
2011-07-15 17:23 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details

Description Kevin Brosnan [:kbrosnan] 2011-06-27 10:36:17 PDT
When panning Firefox mobile in touch.facebook.com the page has white blocks where content is not displayed. Problem happens in landscape or portrait mode.

str:
Open touch.facebook.com
log in
pan the page
Comment 1 Kevin Brosnan [:kbrosnan] 2011-06-27 11:03:25 PDT
Created attachment 542210 [details]
screenshot displaying the issue
Comment 2 Kevin Brosnan [:kbrosnan] 2011-07-10 09:45:53 PDT
*** Bug 670480 has been marked as a duplicate of this bug. ***
Comment 3 CoJaBo 2011-07-10 10:22:01 PDT
Created attachment 545088 [details]
Issue on Droid X

What device was this tested on?

The problem I reported presents differently on my Droid X- the page content is unaffected, but the contents of the text box are cut off in the same fashion. Switching to landscape eliminates the problem (might be resolution dependent).
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-07-12 13:39:22 PDT
I can't reproduce that with a beta build and finkle can't reproduce with a private build from 24 hours ago (changeset 763ff2d737e7). What changesets are you testing with?
Comment 5 CoJaBo 2011-07-12 15:13:27 PDT
I notice I can reproduce this on my Droid X, but not strictly by panning-
Zooming in slightly then back out makes an either off-white or black area obscure the content on the right side as per attachment 1 [details] [diff] [review].
In landscape view, the area appears when panning to the right then remains when panned all the way back to the left.
Tested using Nightly build 2011-07-12.
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2011-07-15 17:23:02 PDT
Created attachment 546261 [details]
SUMO screenshot

I just saw this same issue on SUMO. I opened the tab, switched away from it and then switched back, as I was closing the left tab panel I saw the text disappear mid-swipe.
Comment 7 Kevin Brosnan [:kbrosnan] 2011-07-19 14:59:54 PDT
Check tomorrow's build now that bug 668633 is fixed.
Comment 8 CoJaBo 2011-07-26 17:07:54 PDT
This and bug 670480 appear to be fixed as per bug 668633.
Comment 9 Kevin Brosnan [:kbrosnan] 2011-07-26 18:04:50 PDT
I agree, tested with today's Nightly build.
Comment 10 Andreea Pod 2011-08-24 07:47:22 PDT
Verified fixed on: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a2) Gecko/20110824 Firefox/8.0a2 Fennec/8.0a2
Device: LG Optimus 2X (Android 2.2)

I verified this following the steps from description.

Note You need to log in before you can comment on or make changes to this bug.