Last Comment Bug 668633 - Elements with scrollable overflow are cut off when panning (e.g. Google Reader)
: Elements with scrollable overflow are cut off when panning (e.g. Google Reader)
Status: VERIFIED FIXED
: regression, verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: Panning/Zooming (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: Firefox 7
Assigned To: Benjamin Stover (:stechz)
:
Mentors:
http://people.mozilla.com/~bstover/sc...
: 672880 673145 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-30 14:08 PDT by Thomas Arend [:tarend]
Modified: 2013-12-27 14:20 PST (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Google Reader cut off (150.40 KB, image/png)
2011-06-30 14:08 PDT, Thomas Arend [:tarend]
no flags Details
Elements with scrollable overflow are cut off when panning (2.01 KB, patch)
2011-07-15 14:33 PDT, Benjamin Stover (:stechz)
roc: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Review

Description Thomas Arend [:tarend] 2011-06-30 14:08:43 PDT
Created attachment 543249 [details]
Google Reader cut off

(1) use phony to switch user agent to "Desktop Firefox"
(2) Go to reader.google.com
(3) click on a "long" article and double-click to zoom and pan up and down

Result: (See screenshot) - article gets cut off on the right
Expected: article remains visible
Comment 1 Matt Brubeck (:mbrubeck) 2011-07-06 12:34:40 PDT
This is also easy to see in http://people.mozilla.com/~bstover/scrolling.html

I noticed it in a Fennec 7.0 nightly on Android.
Comment 2 Matt Brubeck (:mbrubeck) 2011-07-06 12:46:07 PDT
We should track this for Fx7; it's a regression that breaks rendering of some pages in Fennec.
Comment 3 Kevin Brosnan [:kbrosnan] 2011-07-06 12:50:38 PDT
is this the same as bug 667516?
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-12 13:42:22 PDT
Still need a regression window.

Ben - can you take a look?
Comment 5 Benjamin Stover (:stechz) 2011-07-15 14:33:34 PDT
Created attachment 546229 [details] [diff] [review]
Elements with scrollable overflow are cut off when panning
Comment 6 Benjamin Stover (:stechz) 2011-07-15 14:35:40 PDT
Comment on attachment 546229 [details] [diff] [review]
Elements with scrollable overflow are cut off when panning

I think this bug must be a regression from 637852. This fixes the issue (and also removes another bug where subsequent sibling layers got the product of all of its previous sibling layers, though I doubt this ever has come up in practice).
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-17 16:58:16 PDT
Comment on attachment 546229 [details] [diff] [review]
Elements with scrollable overflow are cut off when panning

Review of attachment 546229 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 8 Benjamin Stover (:stechz) 2011-07-18 11:07:32 PDT
Pushed to inbound http://hg.mozilla.org/integration/mozilla-inbound/rev/35ed7537c909
Comment 9 Marco Bonardo [::mak] 2011-07-19 07:25:06 PDT
http://hg.mozilla.org/mozilla-central/rev/35ed7537c909
Comment 10 Matt Brubeck (:mbrubeck) 2011-07-19 07:46:03 PDT
Comment on attachment 546229 [details] [diff] [review]
Elements with scrollable overflow are cut off when panning

Requesting approval-mozilla-aurora for this patch, which fixes a regression in Gecko 7 that causes many pages to render incorrectly in Fennec.
Comment 11 Matt Brubeck (:mbrubeck) 2011-07-20 07:14:42 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/e6132405124c
Comment 12 Matt Brubeck (:mbrubeck) 2011-07-20 11:50:29 PDT
*** Bug 672880 has been marked as a duplicate of this bug. ***
Comment 13 Andreea Pod 2011-07-21 09:14:07 PDT
Verified fixed on Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110721 Firefox/7.0a2 Fennec/7.0a2

Device: LG Optimus 2X
Comment 14 Mike Hommey [:glandium] 2011-07-21 23:14:19 PDT
*** Bug 673145 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.