Severe aliasing in resized images

RESOLVED DUPLICATE of bug 486918

Status

()

defect
RESOLVED DUPLICATE of bug 486918
8 years ago
8 years ago

People

(Reporter: ws.bugzilla, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
As described in bug 98971, Firefox does *some* filtering on the images it resizes. However, in my opinion, it is far from adequate. Firefox still shows severe aliasing when shrinking images.

Steps to reproduce the attached image:
- go to http://apod.nasa.gov/apod/ap101029.html
- hold Ctrl+- until the zoom limit is reached

Updated

8 years ago
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
(Reporter)

Comment 1

8 years ago
Attachment shows that even bilinear filtering is much better than what Firefox does.

Comment 2

8 years ago
bug 98971 is for *upscaling*, not downscaling. It uses bilinear filetring.

Downscaling uses nearest neighbor as far as I know, except on Android (bilinear if hardware acceleration is available).

I think this is a dupe of bug 372462 or bug 486918, but there are so many similar bugs out there, that it's not easy to see which is the best to choose.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486918
You need to log in before you can comment on or make changes to this bug.