Remove 'Last page visited' from Preferences > Browser

RESOLVED DUPLICATE of bug 692423

Status

--
trivial
RESOLVED DUPLICATE of bug 692423
8 years ago
7 years ago

People

(Reporter: akilaa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0.1) Gecko/20110608 Firefox/4.0.1 SeaMonkey/2.1
Build ID: 20110608020727

Steps to reproduce:

In 'Browser' section of preferences, the 'Display on Browser Startup' has four choices, Blank page, Home page, Last page visited, and Restore Previous Session. Of these, Last page visited looks like it has no use in this case.


Actual results:

This preference really does what it says: after a restart, it opens nothing more but *the* last page visited, even if there were multiple tabs in that window before restart. I don't know how a regular user would benefit from this sort of functionality.


Expected results:

Choices of the 'Display on Browser Startup' should be reduced to just three: Blank page, Home page, and Restore Previous Session.

Comment 1

8 years ago
(Forgot)

Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110626 Firefox/5.0 SeaMonkey/2.2

Comment 2

8 years ago
^_sorry about that (above post & this one), posted to wrong Bug.
 
 
(Anyhow, since I'm here, since the feature exists, since not everyone uses Tabs, since they may want it to do just what it says ... let it be.)
(Reporter)

Updated

8 years ago
Severity: normal → trivial
OS: Other → All
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> (Anyhow, since I'm here, since the feature exists, since not everyone uses
> Tabs, since they may want it to do just what it says ... let it be.)

So what? If someone doesn't use tabs, 'Restore Previous Session' does exactly the same thing as 'Last page visited'. 'Last page visited' is clearly meant to be used with 'Display in New Tab' and 'Display in New Window' only.
(Reporter)

Comment 4

8 years ago
Created attachment 543731 [details] [diff] [review]
Proposed fix
(Reporter)

Updated

8 years ago
Attachment #543731 - Flags: review?(neil)
Comment on attachment 543731 [details] [diff] [review]
Proposed fix

As I understand it, the preference itself still works even in Firefox, although you would have to set it in about:config in that case. SeaMonkey's UI does try to be more thorough than that of Firefox (for instance we have separate preferences for new windows and tabs which Firefox does not), so I don't think we want to permanently remove this option, although had we been short of space in the pref panel I could have been be convinced to accept a patch that only showed the option if you had already set it previously.
Attachment #543731 - Flags: review?(neil) → review-

Comment 6

7 years ago
Hi, I'm not sure if this is the same problem, but since 2.7.1 "last page visited" is totally broken.  Rather than cloning the tab I'm looking at (which is what it's done since Mozilla days & is what I want) it goes to whatever happens to be the last page loaded from the Internet, which is useless and potentially embarrassing! At least this happens when you create a new tab with the tab preference set to "last page visited".

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 692423
You need to log in before you can comment on or make changes to this bug.