Remove "Last page visited" options from Browser preferences, or reimplement functionality.

RESOLVED FIXED in seamonkey2.7

Status

SeaMonkey
Preferences
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: InvisibleSmiley, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
seamonkey2.7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Bug 691524 removed support for "Last page visited" for Gecko 10. Unless we somehow move and implement the feature in our code, we need to remove the corresponding Preferences options under Browser/Display on [Browser Startup/New Window/New Tab].
(Assignee)

Comment 1

6 years ago
Created attachment 568954 [details] [diff] [review]
Reinstate browser.history.last_page_visited

You may remember removing the last traces of that pref in bug 210752.
Well, this patch brings it back ;-)

I extracted the list of schemes from nsNavHistory.cpp

I used the asciiSpec so that I can use char prefs instead of complex values.
Attachment #568954 - Flags: review?(iann_bugzilla)

Comment 2

6 years ago
(In reply to neil@parkwaycc.co.uk from comment #1)
> Created attachment 568954 [details] [diff] [review] [diff] [details] [review]
> Reinstate browser.history.last_page_visited
> 
> You may remember removing the last traces of that pref in bug 210752.
> Well, this patch brings it back ;-)
> 
> I extracted the list of schemes from nsNavHistory.cpp
> 
> I used the asciiSpec so that I can use char prefs instead of complex values.

The only issue which I can see with using asciiSpec is that the page is something like:
http://موقع.وزارة-الأتصالات.مصر/default.aspx

You briefly see:
http://xn--4gbrim.xn----rmckbbajlc6dj7bxne2c.xn--wgbh1c/default.aspx
in the url bar which is a bit unsightly.

Would using complex values resolve this?
Assignee: nobody → neil
Status: NEW → ASSIGNED

Comment 3

6 years ago
I've also noticed that pages that auto-refresh (google news page for example) will appear as the last page visited, even if you have been other places since opening that auto-refreshing page. Would that be easy to resolve?
(Assignee)

Comment 4

6 years ago
(In reply to Ian Neal from comment #2)
> You briefly see:
> http://xn--4gbrim.xn----rmckbbajlc6dj7bxne2c.xn--wgbh1c/default.aspx
> in the url bar which is a bit unsightly.
> 
> Would using complex values resolve this?

Yes, I'll switch them over.

(In reply to Ian Neal from comment #3)
> I've also noticed that pages that auto-refresh (google news page for
> example) will appear as the last page visited, even if you have been other
> places since opening that auto-refreshing page.

I don't suppose you know what happens in older builds?

Updated

6 years ago
Summary: Remove "Last page visited" options from Browser preferences → Remove "Last page visited" options from Browser preferences, or reimplement functionality.

Comment 5

6 years ago
(In reply to neil@parkwaycc.co.uk from comment #4)
> (In reply to Ian Neal from comment #3)
> > I've also noticed that pages that auto-refresh (google news page for
> > example) will appear as the last page visited, even if you have been other
> > places since opening that auto-refreshing page.
> 
> I don't suppose you know what happens in older builds?
On older builds
Components.classes["@mozilla.org/browser/global-history;2"].getService(Components.interfaces.nsIBrowserHistory).lastPageVisited
also shows google news as the last page visited when it autorefreshes, so no change in behaviour.
(Assignee)

Comment 6

6 years ago
Created attachment 571050 [details] [diff] [review]
Complex patch
Attachment #568954 - Attachment is obsolete: true
Attachment #568954 - Flags: review?(iann_bugzilla)
Attachment #571050 - Flags: review?(iann_bugzilla)

Updated

6 years ago
Attachment #571050 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 7

6 years ago
Pushed changeset a3b479f82595 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Depends on: 700308
tracking-seamonkey2.7: ? → ---
Target Milestone: --- → seamonkey2.7

Updated

6 years ago
Depends on: 726415

Updated

6 years ago
Duplicate of this bug: 667852

Updated

6 years ago
No longer depends on: 726415
(Assignee)

Updated

6 years ago
Depends on: 726415
You need to log in before you can comment on or make changes to this bug.