Closed Bug 667964 Opened 9 years ago Closed 9 years ago

FF 5 :hover pseudo class CSS rules not applied when using class selector

Categories

(Firefox :: General, defect)

5 Branch
All
Other
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 197686

People

(Reporter: jason, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Noticed FF5 will not apply the css pseudo class rules for :hover when the rule uses the class name as a selector for div and li elements.  It does work if the element is an img.

It will however use the rule if an element.class selector is used. So div.className:hover{} or li.className:hover{} works while .className:hover{} does not.

This behavior is new to FF5. Previous versions worked with just the className:hover selector and all other major current browsers (Chrome, Safari, IE, Opera) support it as well.
Can you provide/attach a reduced Testcase showing the Issue?
Maybe also provide a Regression Pushlog against mozilla-central?
http://harthur.github.com/mozregression/
This intended behaviour in quirksmode, see
https://developer.mozilla.org/en/mozilla_quirks_mode_behavior#Miscellaneous_.26_Style

Add a standards mode triggering doctype, you can just use 
<!DOCTYPE html>

(BTW, this is fixed in Firefox 6)
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 197686
(In reply to comment #0)
> This behavior is new to FF5.

AFAICT this was quirksmode behaviour since ages, no?
You need to log in before you can comment on or make changes to this bug.